[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] 回覆: response to BIOS int 0x13 calls

From: bilsch
Subject: Re: [Qemu-discuss] 回覆: response to BIOS int 0x13 calls
Date: Sat, 12 Mar 2016 02:06:35 -0800
User-agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

On 03/11/2016 11:45 PM, address@hidden wrote:
Never tried to format a drive inside the guest.

You start a interesting topic.

I checked wiki -https://en.wikipedia.org/wiki/SeaBIOS.

It says 'SeaBIOS has support for APM 1.2, Enhanced Disk Drive (EDD) 3.0 (INT 
13H extensions), SMBIOS 2.4, MultiProcessor Specification, BIOS Boot 
Specification (BBS) and ACPI. It does not support ESCD.'

Would you check which file of biosloaded??
從: address@hidden <address@hidden> 代表 bilsch <address@hidden>
寄件日期: 2016年03月12日 15:36
至: Dale R. Worley
副本: qemu
主旨: Re: [Qemu-discuss] response to BIOS int 0x13 calls

On 03/11/2016 08:56 AM, Dale R. Worley wrote:
bilsch<address@hidden>  writes:
I'm a low energy QEMU user.  I use it for running a 'hobby' OS that is
little more than a boot sector.  It has a program that calls int 0x13
ah=0x48 to get the number of sectors on the hard drive.  If the call
returns CF=1 it means the call was unsuccessful (and presumably the # of
sectors info is invalid).  If I copy the 'OS' containing this BIOS call
to a partition on the actual hard drive and boot it, it returns CF=0 and
# sectors = (a reasonable number).  If I run this OS in QEMU it returns
CF=1 and # sectors = 0.  How do I get correct BIOS response in QEMU?
Your OS is calling the BIOS that QEMU provides for the virtual machine
that your OS is running inside of.  So the first thing to track down is
what that BIOS is and whether it actually implements INT 0x13.


The QEMU site says it emulates PC BIOS from the Seabios project.  I
looked at the Seabios site and it references many sources.  I'm not sure
how to interpret the info on the Seabios site but they do reference Ralf
Brown Interrupt List.  RBIL info implies Seabios does not support int
0x13/ah=0x48.  I can't imagine why Seabios would not support that.  How
can an OS partition and format a drive if it doesn't know the number of

Bill S.

BIOS is SeaBIOS (version 1.7.4-20150827-223240-lgw01-56)
any more than that I don't know. I don't know how to make QEMU tell me anything more. If it does INT 13 extensions then it should do int13/ah=48. But it's not doing that.

Bill S.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]