[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Emulating A10

From: Peter Maydell
Subject: Re: [Qemu-discuss] Emulating A10
Date: Thu, 5 Nov 2015 22:31:16 +0000

On 5 November 2015 at 21:25, Jerry Stuckle <address@hidden> wrote:
> I'm having trouble trying to emulate an Olimex A10-OlinuXino-Lime
> (https://www.olimex.com/Products/OLinuXino/A10/A10-OLinuXino-LIME/open-source-hardware).

QEMU doesn't have a model of this hardware.

>  To do so, I downloaded the Ubuntu trusty image (also tried Debian
> jessie with the same results), unzipped it and used 'dd' to copy to a
> qcow2 disk (attached with qemu-nbd).
> This comes up with one partition; I mounted it and added links for
> vmlinuz and initrd.img to their respective files in the /boot directory.
>  I then tried to run it with:
> #!/bin/sh
> qemu-system-arm  \
>                 -M vexpress-a9 \

This option says "emulate a Versatile Express Cortex-A9 development
board". Probably the kernel you have doesn't have the support for
that compiled into it.

>                 -m 512M \
>                 -hda /export/armhost/armhf.qcow2 \

This option is trying to connect a hard disk (scsi or IDE),
but the vexpress-a9 doesn't have either of those (you can
boot it via emulated SD card image).

>                 -kernel /vmlinuz \
>                 -initrd /initrd.img \
>                 -append "root=/dev/sda1" \

You usually want something in the 'append' line to tell
the kernel to put the console on the serial port.

>                 -no-reboot
> (right now just trying to get it going).
> The result is a blank window opens and CPU goes to 100%.

This usually means "guest kernel crashed before it got to the
point of sending anything to the UART and/or it didn't know
where the UART on this board is".

Also it seems likely that you'll want to pass QEMU the
correct device tree blob as well as the kernel and initrd.

In general, if all you care about is userspace, you're
probably better trying to find instructions for how to
get (eg) Ubuntu running under QEMU, rather than taking
instructions for running Ubuntu on specific hardware
and trying to somehow get that kernel and disk image
to run on QEMU. If you actually need the exact hardware
emulated then you'll need to implement it in QEMU first...

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]