[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Unable to use -monitor option

From: 邓尧
Subject: [Qemu-discuss] Unable to use -monitor option
Date: Wed, 5 Nov 2014 01:26:26 +0800

I compiled qemu from source, everything seems to be find until I tried to use the -monitor option. qemu was conifgured as following:

'./configure' '--prefix=/opt/App/qemu' '--disable-sdl' '--enable-vnc' '--disable-xen' '--enable-vnc-tls' '--enable-vnc-sasl' '--enable-vnc-jpeg' '--enable-vnc-png' '--disable-curses' '--enable-kvm' '--disable-user' '--target-list=x86_64-softmmu i386-softmmu' '--enable-libusb' '--disable-gtk' '--extra-ldflags=-Wl,-rpath=/usr/local/lib'

The qemu command line is:
qemu-system-i386 x.img -monitor tcp:,nowait,nodelay

Here are the error messages:
qemu-system-i386: -monitor tcp:,nowait,nodelay: Failed to connect to socket: Connection refused
qemu-system-i386: -monitor tcp:,nowait,nodelay: chardev: opening backend "socket" failed

I tried similar command line options on Ubuntu, these options seem to be fine with Ubuntu, but doesn't work with the binaries compiled by myself.

What went wrong ?

Deng Yao

reply via email to

[Prev in Thread] Current Thread [Next in Thread]