[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Unable to use -monitor option

From: 邓尧
Subject: Re: [Qemu-discuss] Unable to use -monitor option
Date: Wed, 5 Nov 2014 01:49:45 +0800

Thanks for replying.
You are right, I missed the "server" option, I even tried to read qemu source code.

On Wed, Nov 5, 2014 at 1:31 AM, Mike Lovell <address@hidden> wrote:
On 11/04/2014 10:26 AM, 邓尧 wrote:
I compiled qemu from source, everything seems to be find until I tried to use the -monitor option. qemu was conifgured as following:

'./configure' '--prefix=/opt/App/qemu' '--disable-sdl' '--enable-vnc' '--disable-xen' '--enable-vnc-tls' '--enable-vnc-sasl' '--enable-vnc-jpeg' '--enable-vnc-png' '--disable-curses' '--enable-kvm' '--disable-user' '--target-list=x86_64-softmmu i386-softmmu' '--enable-libusb' '--disable-gtk' '--extra-ldflags=-Wl,-rpath=/usr/local/lib'

The qemu command line is:
qemu-system-i386 x.img -monitor tcp: <>,nowait,nodelay

Here are the error messages:
qemu-system-i386: -monitor tcp: <>,nowait,nodelay: Failed to connect to socket: Connection refused
qemu-system-i386: -monitor tcp: <>,nowait,nodelay: chardev: opening backend "socket" failed

I tried similar command line options on Ubuntu, these options seem to be fine with Ubuntu, but doesn't work with the binaries compiled by myself.

What went wrong ?

Deng Yao

the options you have provided for the -monitor command instruct qemu to try to connect to is there something listening on that port to receive the connection from qemu? if you are intending for qemu to listen for connections, then you need to add the 'server' option to the monitor options. such as the following.

'-monitor tcp:,nowait,nodelay,server'


reply via email to

[Prev in Thread] Current Thread [Next in Thread]