[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Problem with virtfs in passthrough mode - only root can a

From: Maciej Piechotka
Subject: [Qemu-discuss] Problem with virtfs in passthrough mode - only root can access files and only those owned by root
Date: Sat, 01 Feb 2014 23:24:32 +0100


I've run into troubles running virtfs is passthrough mode (configured by
libvirtd). I've tried running qemu with root:root and root:kvm
privileges but in both cases the situation is the same:

 - root accessing files just fine (mkdir/touch/rmdir) but it cannot
chown them (operation not permitted)
 - if I chown files on the host to user the guest cannot access them
(including root).

I've tried various access parameters on guest but all behave in the same
way (i.e. the one described above). I've tried to google for solution
but all either describing mapped mode (since FS will be shared to
Windows guests as well through CIFS or NFS it's not applicable as they
would not write files 'properly') or just restrict themselves to warning
that qemu needs to run as root (I've checked this is the case by ps).
When I attached strace I could not see any errors.

I'm using Arch on both host and guest and qemu 1.7.0 (with kvm
acceleration). Any idea what is wrong or how to find out what's wrong?

Best regards

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]