[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Migrating Windows XP vm from VirtualBox to Qemu/KVM

From: Sebastian Arcus
Subject: [Qemu-discuss] Migrating Windows XP vm from VirtualBox to Qemu/KVM
Date: Sat, 23 Nov 2013 23:48:28 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.1.0

I am trying to migrate a Windows XP (32bit) vm from VirtualBox to Qemu. There are a number of guides on the internet for migrating vms from VirtualBox to Qemu/KVM, so I've done the following:

1. I've treated this as a motherboard change, as I assume the components available in Qemu don't match exactly the ones in VirtualBox. I followed the steps described here: http://arstechnica.com/gadgets/2007/09/how-to-install-a-new-motherboard-without-reinstalling-windows/ to make my vm hardware agnostic and remove manufacturer specific drivers.

2. I have used VirtualBox to convert the hard-drive image from vdi to raw (although, if I understand correctly, I could have run the vdi image directly in qemu nowadays).

3. I've tried to start the image with a simple command, such as:

    qemu-system-x86_64 -drive file=xp_home_sp3.img,if=ide,index=0

All I get is sometimes nothing in the vm window, and sometimes the following text (exactly as it appears - which looks like it has frozen before displaying the entire line):

SeaBIOS (version rel-1.7.3-0-gc02c219-20130724_153_

I've also tried to start the vdi image, with the same results.

I should mention the following, in case it is relevant:

a. The image used to run on a different computer in VirtualBox, on a 32bit Linux host, with a 32bit CPU (Intel U2500). b. The qemu/kvm install is on a Linux 64bit host, with an Intel Core i3-3227U cpu.
c. The Windows XP vm used to use an ide controller in VirtualBox.

Any hints as to what am I doing wrong? I've googled around, but all I stumble over is straight forward guides, nothing more specific to my situation. I'm inclined to think that it isn't the XP installation itself that is the problem, as I don't even get to see a Windows XP logo or any blue screen of death etc. Maybe I need to set different cpu parameters, or some other hardware parameters in the vm?

Any suggestions appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]