[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Migrating Windows XP vm from VirtualBox to Qemu/KVM

From: dE
Subject: Re: [Qemu-discuss] Migrating Windows XP vm from VirtualBox to Qemu/KVM
Date: Wed, 27 Nov 2013 12:20:24 +0530
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130928 Thunderbird/17.0.9

On 11/24/13 16:58, Sebastian Arcus wrote:

On 24/11/13 08:57, Sebastian Arcus wrote:
On 24/11/13 01:41, Chloride Cull wrote:
Since it's a 32-bit VM, have you tried launching it with
'qemu-system-i386' instead?
I did. I get pretty much the same thing (just a little bit more characters on the "SeaBios ..." line). If I remember correctly thought, it shouldn't matter, as 64bit cpu's are supposed to be backwards compatible with x86.

On 2013-11-24 00:48, Sebastian Arcus wrote:
I am trying to migrate a Windows XP (32bit) vm from VirtualBox to Qemu.
There are a number of guides on the internet for migrating vms from
VirtualBox to Qemu/KVM, so I've done the following:

1. I've treated this as a motherboard change, as I assume the components available in Qemu don't match exactly the ones in VirtualBox. I followed
the steps described here:
http://arstechnica.com/gadgets/2007/09/how-to-install-a-new-motherboard-without-reinstalling-windows/ to make my vm hardware agnostic and remove manufacturer specific drivers.

2. I have used VirtualBox to convert the hard-drive image from vdi to
raw (although, if I understand correctly, I could have run the vdi image
directly in qemu nowadays).

3. I've tried to start the image with a simple command, such as:

     qemu-system-x86_64 -drive file=xp_home_sp3.img,if=ide,index=0

All I get is sometimes nothing in the vm window, and sometimes the
following text (exactly as it appears - which looks like it has frozen
before displaying the entire line):

SeaBIOS (version rel-1.7.3-0-gc02c219-20130724_153_

I've also tried to start the vdi image, with the same results.

I should mention the following, in case it is relevant:

a. The image used to run on a different computer in VirtualBox, on a
32bit Linux host, with a 32bit CPU (Intel U2500).
b. The qemu/kvm install is on a Linux 64bit host, with an Intel Core
i3-3227U cpu.
c. The Windows XP vm used to use an ide controller in VirtualBox.

Any hints as to what am I doing wrong? I've googled around, but all I
stumble over is straight forward guides, nothing more specific to my
situation. I'm inclined to think that it isn't the XP installation
itself that is the problem, as I don't even get to see a Windows XP logo
or any blue screen of death etc. Maybe I need to set different cpu
parameters, or some other hardware parameters in the vm?

Any suggestions appreciated.

I seem to have moved on one step further. I've tried to start qemu/kvm as a root, and I get the following error now:

"Booting from hard-disk ...

A disk read error occurred
Press CTRL+ALT+DEL to restart"

Is there some way to make qemu-system-x86_64 a bit more verbose? I looked through the help options, and there doesn't seem to be one which will make it a bit more talkative on the command line. I wish I could see what it is trying to do and where it fails.

I'd successfully made generic Windows XP and 7 installs (which installs on any partition, not just the 1st). Remembering the efforts, I'ld suggest you 'reinstall'.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]