[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Nographic option broke?

From: Kevin Carpenter
Subject: [Qemu-discuss] Nographic option broke?
Date: Sun, 07 Oct 2012 16:29:36 -0500
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120907 Thunderbird/15.0.1

Hi all -

I had a nice play-around KVM Linux Host with several guest running. It pretty much sat idle shy a BOINC guest off burning up CPU for, oh, perhaps a year. It is Gentoo based and was running a 2.6.38 hardened kernel if that helps date it at all.

Anyhow, had a new project so decided to freshen everything up.

Applied all maintenance to bring the Host up to current levels and am now running a 3.5.4 hardened kernel.

I use to start my Guest via /etc/local.d/local.start with lines like:

echo "Starting up LAMP KVM"
cd /kvm
nice -n 9 kvm -net nic,model=virtio -net tap,ifname=tap1,script=no -drive file=/dev/vg/lamp_vm,if=virtio,boot=on -nographic -daemonize -m 2g -smp 2 -runas kvm -name lampvm,process=lamp-kvm

After refreshing, found that kvm was no longer found, it was now called "qemu-kvm". No biggie, easy to change. Apparently the "boot=on" is dated as well. Again, trivial change.

Alas, when I start the Guest now, they go into a 100% cpu loop.

If I start them with the command like:

qemu-kvm -net nic,model=virtio -net tap,ifname=tap1,script=no -drive file=/dev/vg/lamp_vm,if=virtio,boot=on -curses -no-reboot -m 2g -smp 2 -runas kvm -name lamp,process=lamp-kvm

They boot and run just fine (but tie up a putty window).

Ah, ok. Just tried the above with an added -daemonize option and it worked fine.

So... has "-nographic" been desupported? Seems odd to have to specify -curses for a disconnected process, but whatever works I suppose.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]