[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v5 06/17] include/exec: Introduce TARGET_PAGE_ENTRY_EXTRA
From: |
Richard Henderson |
Subject: |
[PATCH v5 06/17] include/exec: Introduce TARGET_PAGE_ENTRY_EXTRA |
Date: |
Sun, 25 Sep 2022 10:51:13 +0000 |
Allow the target to cache items from the guest page tables.
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
include/exec/cpu-defs.h | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/include/exec/cpu-defs.h b/include/exec/cpu-defs.h
index 5e12cc1854..67239b4e5e 100644
--- a/include/exec/cpu-defs.h
+++ b/include/exec/cpu-defs.h
@@ -163,6 +163,15 @@ typedef struct CPUTLBEntryFull {
/* @lg_page_size contains the log2 of the page size. */
uint8_t lg_page_size;
+
+ /*
+ * Allow target-specific additions to this structure.
+ * This may be used to cache items from the guest cpu
+ * page tables for later use by the implementation.
+ */
+#ifdef TARGET_PAGE_ENTRY_EXTRA
+ TARGET_PAGE_ENTRY_EXTRA
+#endif
} CPUTLBEntryFull;
/*
--
2.34.1
- Re: [PATCH v5 01/17] accel/tcg: Rename CPUIOTLBEntry to CPUTLBEntryFull, (continued)
- [PATCH v5 02/17] accel/tcg: Drop addr member from SavedIOTLB, Richard Henderson, 2022/09/25
- [PATCH v5 03/17] accel/tcg: Suppress auto-invalidate in probe_access_internal, Richard Henderson, 2022/09/25
- [PATCH v5 04/17] accel/tcg: Introduce probe_access_full, Richard Henderson, 2022/09/25
- [PATCH v5 05/17] accel/tcg: Introduce tlb_set_page_full, Richard Henderson, 2022/09/25
- [PATCH v5 06/17] include/exec: Introduce TARGET_PAGE_ENTRY_EXTRA,
Richard Henderson <=
- [PATCH v5 07/17] target/sparc: Use tlb_set_page_full, Richard Henderson, 2022/09/25
- [PATCH v5 08/17] accel/tcg: Move byte_swap from MemTxAttrs to CPUTLBEntryFull, Richard Henderson, 2022/09/25
- [PATCH v5 09/17] accel/tcg: Add force_aligned to CPUTLBEntryFull, Richard Henderson, 2022/09/25
- [PATCH v5 10/17] accel/tcg: Remove PageDesc code_bitmap, Richard Henderson, 2022/09/25
- [PATCH v5 11/17] accel/tcg: Use bool for page_find_alloc, Richard Henderson, 2022/09/25
- [PATCH v5 12/17] accel/tcg: Use DisasContextBase in plugin_gen_tb_start, Richard Henderson, 2022/09/25
- [PATCH v5 13/17] accel/tcg: Do not align tb->page_addr[0], Richard Henderson, 2022/09/25