[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v3 00/20] ppc4xx_sdram QOMify and clean ups
From: |
Cédric Le Goater |
Subject: |
Re: [PATCH v3 00/20] ppc4xx_sdram QOMify and clean ups |
Date: |
Wed, 14 Sep 2022 09:29:51 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.2.1 |
On 9/13/22 21:52, BALATON Zoltan wrote:
This is the end of the QOMify series started by Cédric. This series
handles the SDRAM controller models to clean them up, QOMify and unify
them and at least partially clean up the mess that has accumulated
around these in the past. This includes the not yet merged patches
from the last series and new ones that change the DDR2 version used by
sam460ex.
I made comments on the first ~10 patches. Let's try to agree on these
first. We will see the remaining ones in a second patchset.
Thanks,
C.
v3: Fix patches that got squashed during rebase
v2: address some review comments and try to avoid compile problem with
gcc 12.2 (untested)
BALATON Zoltan (20):
ppc440_bamboo: Remove unnecessary memsets
ppc4xx: Introduce Ppc4xxSdramBank struct
ppc4xx_sdram: Get rid of the init RAM hack
ppc4xx: Use Ppc4xxSdramBank in ppc4xx_sdram_banks()
ppc440_bamboo: Add missing 4 MiB valid memory size
ppc4xx_sdram: Move size check to ppc4xx_sdram_init()
ppc4xx_sdram: QOM'ify
ppc4xx_sdram: Drop extra zeros for readability
ppc440_sdram: Split off map/unmap of sdram banks for later reuse
ppc440_sdram: Implement enable bit in the DDR2 SDRAM
ppc440_sdram: Get rid of the init RAM hack
ppc440_sdram: Rename local variable for readibility
ppc4xx_sdram: Rename functions to prevent name clashes
ppc440_sdram: Move RAM size check to ppc440_sdram_init
ppc440_sdram: QOM'ify
ppc4xx_sdram: Move ppc4xx DDR and DDR2 SDRAM controller models
together
ppc4xx_sdram: Use hwaddr for memory bank size
ppc4xx_sdram: Rename local state variable for brevity
ppc4xx_sdram: Generalise bank setup
ppc4xx_sdram: Convert DDR SDRAM controller to new bank handling
hw/ppc/meson.build | 3 +-
hw/ppc/ppc405.h | 8 +-
hw/ppc/ppc405_boards.c | 22 +-
hw/ppc/ppc405_uc.c | 33 +-
hw/ppc/ppc440.h | 4 -
hw/ppc/ppc440_bamboo.c | 29 +-
hw/ppc/ppc440_uc.c | 267 +--------------
hw/ppc/ppc4xx_devs.c | 413 -----------------------
hw/ppc/ppc4xx_sdram.c | 723 ++++++++++++++++++++++++++++++++++++++++
hw/ppc/sam460ex.c | 48 +--
hw/ppc/trace-events | 1 +
include/hw/ppc/ppc4xx.h | 66 +++-
12 files changed, 847 insertions(+), 770 deletions(-)
create mode 100644 hw/ppc/ppc4xx_sdram.c
- Re: [PATCH v3 12/20] ppc440_sdram: Rename local variable for readibility, (continued)
- [PATCH v3 11/20] ppc440_sdram: Get rid of the init RAM hack, BALATON Zoltan, 2022/09/13
- [PATCH v3 14/20] ppc440_sdram: Move RAM size check to ppc440_sdram_init, BALATON Zoltan, 2022/09/13
- [PATCH v3 13/20] ppc4xx_sdram: Rename functions to prevent name clashes, BALATON Zoltan, 2022/09/13
- [PATCH v3 17/20] ppc4xx_sdram: Use hwaddr for memory bank size, BALATON Zoltan, 2022/09/13
- [PATCH v3 18/20] ppc4xx_sdram: Rename local state variable for brevity, BALATON Zoltan, 2022/09/13
- [PATCH v3 15/20] ppc440_sdram: QOM'ify, BALATON Zoltan, 2022/09/13
- [PATCH v3 16/20] ppc4xx_sdram: Move ppc4xx DDR and DDR2 SDRAM controller models together, BALATON Zoltan, 2022/09/13
- [PATCH v3 19/20] ppc4xx_sdram: Generalise bank setup, BALATON Zoltan, 2022/09/13
- [PATCH v3 20/20] ppc4xx_sdram: Convert DDR SDRAM controller to new bank handling, BALATON Zoltan, 2022/09/13
- Re: [PATCH v3 00/20] ppc4xx_sdram QOMify and clean ups,
Cédric Le Goater <=