[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 21/28] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCm
From: |
Eric Blake |
Subject: |
Re: [PATCH 21/28] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd() |
Date: |
Tue, 23 Mar 2021 10:11:14 -0500 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.8.1 |
On 3/23/21 4:40 AM, Markus Armbruster wrote:
> Commit 967c885108 "qapi: add 'if' to top-level expressions" added
> command TestIfCmd with an 'if' condition. It also added the
> qmp_TestIfCmd() to go with it, guarded by the corresponding #if.
> Commit ccadd6bcba "qapi: Add 'if' to implicit struct members" changed
> the command, but not the function. Compiles only because we don't
> satisfy the #if. Instead of fixing the function, simply drop it.
>
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
> tests/unit/test-qmp-cmds.c | 7 -------
> 1 file changed, 7 deletions(-)
Reviewed-by: Eric Blake <eblake@redhat.com>
>
> diff --git a/tests/unit/test-qmp-cmds.c b/tests/unit/test-qmp-cmds.c
> index 266db074b4..99973dde7c 100644
> --- a/tests/unit/test-qmp-cmds.c
> +++ b/tests/unit/test-qmp-cmds.c
> @@ -13,13 +13,6 @@
>
> static QmpCommandList qmp_commands;
>
> -#if defined(TEST_IF_STRUCT) && defined(TEST_IF_CMD)
> -UserDefThree *qmp_TestIfCmd(TestIfStruct *foo, Error **errp)
> -{
> - return NULL;
> -}
> -#endif
> -
> UserDefThree *qmp_TestCmdReturnDefThree(Error **errp)
> {
> return NULL;
>
--
Eric Blake, Principal Software Engineer
Red Hat, Inc. +1-919-301-3226
Virtualization: qemu.org | libvirt.org
- Re: [PATCH 24/28] qapi: Enforce command naming rules, (continued)
- [PATCH 25/28] tests/qapi-schema: Switch member name clash test to struct, Markus Armbruster, 2021/03/23
- [PATCH 16/28] qapi: Factor out QAPISchemaParser._check_pragma_list_of_str(), Markus Armbruster, 2021/03/23
- [PATCH 27/28] qapi: Enforce enum member naming rules, Markus Armbruster, 2021/03/23
- [PATCH 23/28] qapi: Enforce feature naming rules, Markus Armbruster, 2021/03/23
- [PATCH 21/28] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd(), Markus Armbruster, 2021/03/23
- Re: [PATCH 21/28] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd(),
Eric Blake <=
- [PATCH 18/28] tests/qapi-schema: Rename returns-whitelist to returns-bad-type, Markus Armbruster, 2021/03/23
- [PATCH 28/28] qapi: Enforce union and alternate branch naming rules, Markus Armbruster, 2021/03/23
- [PATCH 13/28] qapi: Enforce event naming rules, Markus Armbruster, 2021/03/23