[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 29/29] tcg: Move tcg_init_ctx and tcg_ctx from accel/tcg/
From: |
Richard Henderson |
Subject: |
[PATCH v2 29/29] tcg: Move tcg_init_ctx and tcg_ctx from accel/tcg/ |
Date: |
Sun, 14 Mar 2021 15:27:24 -0600 |
These variables belong to the jit side, not the user side.
Since tcg_init_ctx is no longer used outside of tcg/, move
the declaration to tcg/internal.h.
Suggested-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
include/tcg/tcg.h | 1 -
tcg/internal.h | 1 +
accel/tcg/translate-all.c | 3 ---
tcg/tcg.c | 3 +++
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/tcg/tcg.h b/include/tcg/tcg.h
index a19deb529f..eef8857cca 100644
--- a/include/tcg/tcg.h
+++ b/include/tcg/tcg.h
@@ -690,7 +690,6 @@ static inline bool temp_readonly(TCGTemp *ts)
return ts->kind >= TEMP_FIXED;
}
-extern TCGContext tcg_init_ctx;
extern __thread TCGContext *tcg_ctx;
extern const void *tcg_code_gen_epilogue;
extern uintptr_t tcg_splitwx_diff;
diff --git a/tcg/internal.h b/tcg/internal.h
index f9906523da..181f86507a 100644
--- a/tcg/internal.h
+++ b/tcg/internal.h
@@ -27,6 +27,7 @@
#define TCG_HIGHWATER 1024
+extern TCGContext tcg_init_ctx;
extern TCGContext **tcg_ctxs;
extern unsigned int tcg_cur_ctxs;
extern unsigned int tcg_max_ctxs;
diff --git a/accel/tcg/translate-all.c b/accel/tcg/translate-all.c
index 40aeecf611..b32760c253 100644
--- a/accel/tcg/translate-all.c
+++ b/accel/tcg/translate-all.c
@@ -218,9 +218,6 @@ static int v_l2_levels;
static void *l1_map[V_L1_MAX_SIZE];
-/* code generation context */
-TCGContext tcg_init_ctx;
-__thread TCGContext *tcg_ctx;
TBContext tb_ctx;
static void page_table_config_init(void)
diff --git a/tcg/tcg.c b/tcg/tcg.c
index 65f9cf01d5..77335fb60f 100644
--- a/tcg/tcg.c
+++ b/tcg/tcg.c
@@ -149,6 +149,9 @@ static int tcg_target_const_match(tcg_target_long val,
TCGType type,
static int tcg_out_ldst_finalize(TCGContext *s);
#endif
+TCGContext tcg_init_ctx;
+__thread TCGContext *tcg_ctx;
+
TCGContext **tcg_ctxs;
unsigned int tcg_cur_ctxs;
unsigned int tcg_max_ctxs;
--
2.25.1
- [PATCH v2 15/29] tcg: Move MAX_CODE_GEN_BUFFER_SIZE to tcg-target.h, (continued)
- [PATCH v2 15/29] tcg: Move MAX_CODE_GEN_BUFFER_SIZE to tcg-target.h, Richard Henderson, 2021/03/14
- [PATCH v2 16/29] tcg: Replace region.end with region.total_size, Richard Henderson, 2021/03/14
- [PATCH v2 20/29] tcg: Move in_code_gen_buffer and tests to region.c, Richard Henderson, 2021/03/14
- [PATCH v2 17/29] tcg: Rename region.start to region.after_prologue, Richard Henderson, 2021/03/14
- [PATCH v2 19/29] tcg: Tidy split_cross_256mb, Richard Henderson, 2021/03/14
- [PATCH v2 18/29] tcg: Tidy tcg_n_regions, Richard Henderson, 2021/03/14
- [PATCH v2 23/29] tcg: Sink qemu_madvise call to common code, Richard Henderson, 2021/03/14
- [PATCH v2 26/29] tcg: Round the tb_size default from qemu_get_host_physmem, Richard Henderson, 2021/03/14
- [PATCH v2 24/29] tcg: Do not set guard pages in the rx buffer, Richard Henderson, 2021/03/14
- [PATCH v2 28/29] tcg: When allocating for !splitwx, begin with PROT_NONE, Richard Henderson, 2021/03/14
- [PATCH v2 29/29] tcg: Move tcg_init_ctx and tcg_ctx from accel/tcg/,
Richard Henderson <=
- [PATCH v2 25/29] util/osdep: Add qemu_mprotect_rw, Richard Henderson, 2021/03/14
- [PATCH v2 21/29] tcg: Allocate code_gen_buffer into struct tcg_region_state, Richard Henderson, 2021/03/14
- [PATCH v2 27/29] tcg: Merge buffer protection and guard page protection, Richard Henderson, 2021/03/14
- [PATCH v2 22/29] tcg: Return the map protection from alloc_code_gen_buffer, Richard Henderson, 2021/03/14
- Re: [PATCH v2 00/29] tcg: Workaround macOS 11.2 mprotect bug, no-reply, 2021/03/14
- Re: [PATCH v2 00/29] tcg: Workaround macOS 11.2 mprotect bug, Roman Bolshakov, 2021/03/15