[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 17/29] tcg: Rename region.start to region.after_prologue
From: |
Richard Henderson |
Subject: |
[PATCH v2 17/29] tcg: Rename region.start to region.after_prologue |
Date: |
Sun, 14 Mar 2021 15:27:12 -0600 |
Give the field a name reflecting its actual meaning.
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
tcg/region.c | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/tcg/region.c b/tcg/region.c
index 8e4dd0480b..23261561a1 100644
--- a/tcg/region.c
+++ b/tcg/region.c
@@ -46,8 +46,8 @@ struct tcg_region_state {
QemuMutex lock;
/* fields set at init time */
- void *start;
void *start_aligned;
+ void *after_prologue;
size_t total_size; /* size of entire buffer */
size_t n;
size_t size; /* size of one region */
@@ -276,7 +276,7 @@ static void tcg_region_bounds(size_t curr_region, void
**pstart, void **pend)
end = start + region.size;
if (curr_region == 0) {
- start = region.start;
+ start = region.after_prologue;
}
if (curr_region == region.n - 1) {
end = region.start_aligned + region.total_size;
@@ -851,7 +851,7 @@ void tcg_region_init(size_t tb_size, int splitwx, unsigned
max_cpus)
region.n = n_regions;
region.size = region_size - page_size;
region.stride = region_size;
- region.start = buf;
+ region.after_prologue = buf;
region.start_aligned = aligned;
/* page-align the end, since its last page will be a guard page */
end = QEMU_ALIGN_PTR_DOWN(buf + total_size, page_size);
@@ -888,15 +888,16 @@ void tcg_region_init(size_t tb_size, int splitwx,
unsigned max_cpus)
void tcg_region_prologue_set(TCGContext *s)
{
/* Deduct the prologue from the first region. */
- g_assert(region.start == s->code_gen_buffer);
- region.start = s->code_ptr;
+ g_assert(region.start_aligned == s->code_gen_buffer);
+ region.after_prologue = s->code_ptr;
/* Recompute boundaries of the first region. */
tcg_region_assign(s, 0);
/* Register the balance of the buffer with gdb. */
- tcg_register_jit(tcg_splitwx_to_rx(region.start),
- region.start_aligned + region.total_size - region.start);
+ tcg_register_jit(tcg_splitwx_to_rx(region.after_prologue),
+ region.start_aligned + region.total_size -
+ region.after_prologue);
}
/*
--
2.25.1
- [PATCH v2 07/29] tcg: Split out region.c, (continued)
- [PATCH v2 07/29] tcg: Split out region.c, Richard Henderson, 2021/03/14
- [PATCH v2 09/29] accel/tcg: Move alloc_code_gen_buffer to tcg/region.c, Richard Henderson, 2021/03/14
- [PATCH v2 11/29] tcg: Create tcg_init, Richard Henderson, 2021/03/14
- [PATCH v2 12/29] accel/tcg: Merge tcg_exec_init into tcg_init_machine, Richard Henderson, 2021/03/14
- [PATCH v2 10/29] accel/tcg: Rename tcg_init to tcg_init_machine, Richard Henderson, 2021/03/14
- [PATCH v2 13/29] accel/tcg: Pass down max_cpus to tcg_init, Richard Henderson, 2021/03/14
- [PATCH v2 14/29] tcg: Introduce tcg_max_ctxs, Richard Henderson, 2021/03/14
- [PATCH v2 15/29] tcg: Move MAX_CODE_GEN_BUFFER_SIZE to tcg-target.h, Richard Henderson, 2021/03/14
- [PATCH v2 16/29] tcg: Replace region.end with region.total_size, Richard Henderson, 2021/03/14
- [PATCH v2 20/29] tcg: Move in_code_gen_buffer and tests to region.c, Richard Henderson, 2021/03/14
- [PATCH v2 17/29] tcg: Rename region.start to region.after_prologue,
Richard Henderson <=
- [PATCH v2 19/29] tcg: Tidy split_cross_256mb, Richard Henderson, 2021/03/14
- [PATCH v2 18/29] tcg: Tidy tcg_n_regions, Richard Henderson, 2021/03/14
- [PATCH v2 23/29] tcg: Sink qemu_madvise call to common code, Richard Henderson, 2021/03/14
- [PATCH v2 26/29] tcg: Round the tb_size default from qemu_get_host_physmem, Richard Henderson, 2021/03/14
- [PATCH v2 24/29] tcg: Do not set guard pages in the rx buffer, Richard Henderson, 2021/03/14
- [PATCH v2 28/29] tcg: When allocating for !splitwx, begin with PROT_NONE, Richard Henderson, 2021/03/14
- [PATCH v2 29/29] tcg: Move tcg_init_ctx and tcg_ctx from accel/tcg/, Richard Henderson, 2021/03/14
- [PATCH v2 25/29] util/osdep: Add qemu_mprotect_rw, Richard Henderson, 2021/03/14
- [PATCH v2 21/29] tcg: Allocate code_gen_buffer into struct tcg_region_state, Richard Henderson, 2021/03/14