[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 2/7] target/tricore: Replace magic value by MMU_DATA_LOAD definiti
From: |
Bastian Koppelmann |
Subject: |
[PULL 2/7] target/tricore: Replace magic value by MMU_DATA_LOAD definition |
Date: |
Sun, 14 Mar 2021 14:55:08 +0100 |
From: Philippe Mathieu-Daudé <f4bug@amsat.org>
cpu_get_phys_page_debug() uses 'DATA LOAD' MMU access type.
Reviewed-by: Bastian Koppelmann <kbastian@mail.uni-paderborn.de>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20210127224255.3505711-2-f4bug@amsat.org>
Signed-off-by: Bastian Koppelmann <kbastian@mail.uni-paderborn.de>
---
target/tricore/helper.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/target/tricore/helper.c b/target/tricore/helper.c
index 7715293263..81171db833 100644
--- a/target/tricore/helper.c
+++ b/target/tricore/helper.c
@@ -50,7 +50,8 @@ hwaddr tricore_cpu_get_phys_page_debug(CPUState *cs, vaddr
addr)
int prot;
int mmu_idx = cpu_mmu_index(&cpu->env, false);
- if (get_physical_address(&cpu->env, &phys_addr, &prot, addr, 0, mmu_idx)) {
+ if (get_physical_address(&cpu->env, &phys_addr, &prot, addr,
+ MMU_DATA_LOAD, mmu_idx)) {
return -1;
}
return phys_addr;
--
2.30.1
- [PULL 0/7] tricore queue, Bastian Koppelmann, 2021/03/14
- [PULL 2/7] target/tricore: Replace magic value by MMU_DATA_LOAD definition,
Bastian Koppelmann <=
- [PULL 1/7] tricore: added triboard with tc27x_soc, Bastian Koppelmann, 2021/03/14
- [PULL 3/7] target/tricore: Pass MMUAccessType to get_physical_address(), Bastian Koppelmann, 2021/03/14
- [PULL 4/7] target/tricore: Remove unused definitions, Bastian Koppelmann, 2021/03/14
- [PULL 5/7] tricore: fixed faulty conditions for extr and imask, Bastian Koppelmann, 2021/03/14
- [PULL 6/7] target/tricore: Fix imask OPC2_32_RRPW_IMASK for r3+1 == r2, Bastian Koppelmann, 2021/03/14
- [PULL 7/7] target/tricore: Fix OPC2_32_RRPW_EXTR for width=0, Bastian Koppelmann, 2021/03/14
- Re: [PULL 0/7] tricore queue, Peter Maydell, 2021/03/15