qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH-for-5.0 v3 4/6] hw/pci-host/i440fx: Use definitions instead o


From: Thomas Huth
Subject: Re: [PATCH-for-5.0 v3 4/6] hw/pci-host/i440fx: Use definitions instead of magic values
Date: Mon, 9 Dec 2019 11:08:13 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 09/12/2019 10.50, Philippe Mathieu-Daudé wrote:
> Use definitions from "hw/pci/pci_regs.h".
> This also helps when using git-grep.
> 
> Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
> ---
>  hw/pci-host/i440fx.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/hw/pci-host/i440fx.c b/hw/pci-host/i440fx.c
> index 0cc80b276d..414138595b 100644
> --- a/hw/pci-host/i440fx.c
> +++ b/hw/pci-host/i440fx.c
> @@ -376,13 +376,13 @@ typedef struct {
>  
>  /* Here we just expose minimal host bridge offset subset. */
>  static const IGDHostInfo igd_host_bridge_infos[] = {
> -    {0x08, 2},  /* revision id */
> -    {0x2c, 2},  /* sybsystem vendor id */
> -    {0x2e, 2},  /* sybsystem id */
> -    {0x50, 2},  /* SNB: processor graphics control register */
> -    {0x52, 2},  /* processor graphics control register */
> -    {0xa4, 4},  /* SNB: graphics base of stolen memory */
> -    {0xa8, 4},  /* SNB: base of GTT stolen memory */
> +    {PCI_REVISION_ID,         2},
> +    {PCI_SUBSYSTEM_VENDOR_ID, 2},
> +    {PCI_SUBSYSTEM_ID,        2},
> +    {0x50,                    2}, /* SNB: processor graphics control 
> register */
> +    {0x52,                    2}, /* processor graphics control register */
> +    {0xa4,                    4}, /* SNB: graphics base of stolen memory */
> +    {0xa8,                    4}, /* SNB: base of GTT stolen memory */
>  };
>  
>  static void host_pci_config_read(int pos, int len, uint32_t *val, Error 
> **errp)
> 

Reviewed-by: Thomas Huth <address@hidden>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]