[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH-for-5.0 v3 3/6] hw/pci-host/i440fx: Use size_t to iterate over AR
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH-for-5.0 v3 3/6] hw/pci-host/i440fx: Use size_t to iterate over ARRAY_SIZE() |
Date: |
Mon, 9 Dec 2019 10:49:59 +0100 |
We don't enforce the -Wsign-conversion CPPFLAG, but it doesn't hurt
to avoid this warning:
warning: implicit conversion changes signedness: 'int' to 'size_t' (aka
'unsigned long') [-Wsign-conversion]
Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
---
hw/pci-host/i440fx.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/hw/pci-host/i440fx.c b/hw/pci-host/i440fx.c
index fbdc563599..0cc80b276d 100644
--- a/hw/pci-host/i440fx.c
+++ b/hw/pci-host/i440fx.c
@@ -419,12 +419,11 @@ out:
static void igd_pt_i440fx_realize(PCIDevice *pci_dev, Error **errp)
{
uint32_t val = 0;
- int i, num;
+ size_t i;
int pos, len;
Error *local_err = NULL;
- num = ARRAY_SIZE(igd_host_bridge_infos);
- for (i = 0; i < num; i++) {
+ for (i = 0; i < ARRAY_SIZE(igd_host_bridge_infos); i++) {
pos = igd_host_bridge_infos[i].offset;
len = igd_host_bridge_infos[i].len;
host_pci_config_read(pos, len, &val, &local_err);
--
2.21.0
[PATCH-for-5.0 v3 4/6] hw/pci-host/i440fx: Use definitions instead of magic values, Philippe Mathieu-Daudé, 2019/12/09
[PATCH-for-5.0 v3 5/6] hw/pci-host/i440fx: Extract the IGD passthrough host bridge device, Philippe Mathieu-Daudé, 2019/12/09
[PATCH-for-5.0 v3 6/6] hw/pci-host: Add Kconfig entry to select the IGD Passthrough Host Bridge, Philippe Mathieu-Daudé, 2019/12/09