[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 08/40] target/arm: Rename ARMMMUIdx*_S12NSE* to ARMMMUIdx*
Re: [PATCH v4 08/40] target/arm: Rename ARMMMUIdx*_S12NSE* to ARMMMUIdx*_E10_*
Fri, 6 Dec 2019 18:01:10 +0000
On Fri, 6 Dec 2019 at 18:00, Richard Henderson
> On 12/6/19 7:45 AM, Peter Maydell wrote:
> > On Tue, 3 Dec 2019 at 02:29, Richard Henderson
> > <address@hidden> wrote:
> >> This is part of a reorganization to the set of mmu_idx.
> >> This emphasizes that they apply to the EL1&0 regime.
> > It loses the important point that they are stage 1&2
> > translations rather than stage 1 or stage 2, though,
> > and also now they're out of line with the naming convention
> > that all the other indexes use :-(
> It won't be out of line once all of the other renamings are done.
I think it might be easier to review if I could see
the intended final set of names in one place (eg in
the commit message to this patch), rather than getting
them a bit at a time (though that is definitely the right
way to structure the code changes themselves).
- [PATCH v4 06/40] target/arm: Split out vae1_tlbmask, vmalle1_tlbmask, (continued)
- [PATCH v4 13/40] target/arm: Rename ARMMMUIdx_S1E2 to ARMMMUIdx_E2, Richard Henderson, 2019/12/02
- [PATCH v4 07/40] target/arm: Simplify tlb_force_broadcast alternatives, Richard Henderson, 2019/12/02
- [PATCH v4 09/40] target/arm: Rename ARMMMUIdx_S2NS to ARMMMUIdx_Stage2, Richard Henderson, 2019/12/02
- [PATCH v4 10/40] target/arm: Rename ARMMMUIdx_S1NSE* to ARMMMUIdx_Stage1_E*, Richard Henderson, 2019/12/02