On Mon, Jul 01, 2019 at 03:34:51PM -0300, Eduardo Habkost wrote:
Agreed that kvm:tcg fallback I suggested isn't a good idea.
However, do we really want to require a separate test method to
be written just because we want to use a different accelerator or
other QEMU option?
No, in the short term we want to have tests that can respond to a
number of well known parameters, such as "accel". But to actually
have tests (names) that are meaningful enough, we need to:
1) Add a varianter implementation (or usage)
2) Drop the duplicate tests
#1 is needed because:
a) it doesn't feel right to name tests based on simple command
line parameters (the ones given with -p, say, "-p accel=kvm"
will add to the test name "accel_kvm".
b) a variant *name* is added to the test ID, which then can be
kept consistent.
Then we can proceed to #2, and drop the duplicate tests, say:
- test_x86_64_pc, test_x86_64_pc_kvm => test_x86_64_pc
On a further iteration, it may even make sense to consolidate:
- test_x86_64_pc, test_x86_64_q35 => test_x86_64
Time will tell.
This patch may be the simplest solution short term, but can we
have something that doesn't require so much code duplication and
boilerplate code in the future?
Yes, the new implementation of the Varianter CIT is now generally
available on Avocado 70.0, so I'm working on a file that hopefully
will suite the acceptance tests.