[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v5 07/12] blockdev: accept io_uring as option
From: |
Stefan Hajnoczi |
Subject: |
Re: [Qemu-devel] [PATCH v5 07/12] blockdev: accept io_uring as option |
Date: |
Wed, 19 Jun 2019 11:24:34 +0100 |
User-agent: |
Mutt/1.11.4 (2019-03-13) |
On Mon, Jun 17, 2019 at 04:01:45PM +0300, Maxim Levitsky wrote:
> On Mon, 2019-06-10 at 19:19 +0530, Aarushi Mehta wrote:
> > Signed-off-by: Aarushi Mehta <address@hidden>
> > Reviewed-by: Stefan Hajnoczi <address@hidden>
> > ---
> > blockdev.c | 4 +++-
> > 1 file changed, 3 insertions(+), 1 deletion(-)
> >
> > diff --git a/blockdev.c b/blockdev.c
> > index 3f44b891eb..a2a5b32604 100644
> > --- a/blockdev.c
> > +++ b/blockdev.c
> > @@ -386,6 +386,8 @@ static void extract_common_blockdev_options(QemuOpts
> > *opts, int *bdrv_flags,
> > if ((aio = qemu_opt_get(opts, "aio")) != NULL) {
> > if (!strcmp(aio, "native")) {
> > *bdrv_flags |= BDRV_O_NATIVE_AIO;
> > + } else if (!strcmp(aio, "io_uring")) {
> > + *bdrv_flags |= BDRV_O_IO_URING;
> > } else if (!strcmp(aio, "threads")) {
> > /* this is the default */
> > } else {
> > @@ -4579,7 +4581,7 @@ QemuOptsList qemu_common_drive_opts = {
> > },{
> > .name = "aio",
> > .type = QEMU_OPT_STRING,
> > - .help = "host AIO implementation (threads, native)",
> > + .help = "host AIO implementation (threads, native, io_uring)",
> > },{
> > .name = BDRV_OPT_CACHE_WB,
> > .type = QEMU_OPT_BOOL,
>
> Nitpick: Maybe we should rename the native to libaio (accept both but give an
> deprication warning)?
"libaio" is a clearer name but I'm afraid changing it or introducing a
new name is not worth it with so many users, command-lines, scripts, and
management tools that know about "native". Having two names that mean
the same thing might cause confusion.
Let's leave it as is.
Stefan
signature.asc
Description: PGP signature
- Re: [Qemu-devel] [PATCH v5 04/12] block/io_uring: implements interfaces for io_uring, (continued)
[Qemu-devel] [PATCH v5 06/12] util/async: add aio interfaces for io_uring, Aarushi Mehta, 2019/06/10
[Qemu-devel] [PATCH v5 08/12] block/file-posix.c: extend to use io_uring, Aarushi Mehta, 2019/06/10
[Qemu-devel] [PATCH v5 07/12] blockdev: accept io_uring as option, Aarushi Mehta, 2019/06/10
[Qemu-devel] [PATCH v5 09/12] block: add trace events for io_uring, Aarushi Mehta, 2019/06/10
[Qemu-devel] [PATCH v5 10/12] block/io_uring: adds userspace completion polling, Aarushi Mehta, 2019/06/10
[Qemu-devel] [PATCH v5 11/12] qemu-io: adds support for io_uring, Aarushi Mehta, 2019/06/10