[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] RFC: memory API changes

From: Peter Maydell
Subject: Re: [Qemu-devel] RFC: memory API changes
Date: Mon, 23 Mar 2015 12:33:19 +0000

On 23 March 2015 at 12:30, Andreas Färber <address@hidden> wrote:
> Am 23.03.2015 um 13:24 schrieb Peter Maydell:
>>  * address_space_rw &c to be renamed:
>>     address_space_rw -> as_rw_buf
>>     address_space_read -> as_read_buf
>>     address_space_write -> as_write_buf
>>     address_space_map -> as_map_buf &c
>>    This is just so the names line up nicely and we have a
>>    clear indication that this is a family of functions
> How does address_space_* not indicate they are a family? address_space_
> is much more intuitive to read than shortening it to as_, which can
> confusingly be read as another English word.

Sorry, that was a little cryptic in retrospect. I meant "they should
have the same prefix as the renamed ld*_phys functions, to indicate
that all of these functions are in the same family rather than being
two sets of unrelated functions". As I note later on, if we want the
prefix to be address_space_ rather than as_ for all these
we could do that, though it's a little long and unwieldy.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]