[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] configure: bump glib version to 2.16

From: John Snow
Subject: Re: [Qemu-devel] [PATCH] configure: bump glib version to 2.16
Date: Tue, 10 Mar 2015 13:43:14 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.4.0

On 03/10/2015 01:41 PM, Peter Maydell wrote:

On 10 March 2015 at 17:37, John Snow <address@hidden
<mailto:address@hidden>> wrote:

    Our qtest suite relies on many functions available only in glib 2.16+.
    Even though our base QEMU binary may only require 2.12+, it is confusing
    to have two separate version requirements.

    Thus, this is an attempt to re-establish a sane baseline for the entire
    project at 2.16+.

Why 2.16 rather than the 2.22 that we seem to have converged
on in discussions on-list?

-- PMM

Wasn't aware we were actually going through with that; it had looked like we were going to refrain from fiddling with it because we found a workaround that sufficed for glib 2.12.

2.16 is just the minimum that qtests currently actually requires.

If, however, we *are* going to shoot for 2.22, then NACK this and let's do that instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]