[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion fun
From: |
David Gibson |
Subject: |
Re: [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion functions |
Date: |
Tue, 30 Sep 2014 18:07:29 +1000 |
User-agent: |
Mutt/1.5.23 (2014-03-12) |
On Tue, Sep 30, 2014 at 09:59:30AM +0200, Gerd Hoffmann wrote:
> Hi,
>
> > > case 15:
> > > - v = VGA_DRAW_LINE15;
> > > + v = big_endian_fb ? VGA_DRAW_LINE15_BE : VGA_DRAW_LINE15_LE;
> > > bits = 16;
> > > break;
> > > case 16:
> > > - v = VGA_DRAW_LINE16;
> > > + v = big_endian_fb ? VGA_DRAW_LINE16_BE : VGA_DRAW_LINE16_LE;
> > > bits = 16;
> > > break;
> >
> > So, v1 changed both of these cases to bits = 15, which looked wrong
> > for case 16. v2 changes neither, which looks wrong for case 15. Or
> > is there a reason it should be 16 for case 15?
>
> It is correct. The '15' is the color depth, and 'bits' is the number of
> bits per pixel, which is 16 because the color format uses two bytes per
> pixel and one of the bits is unused.
Ok, then:
Reviewed-by: David Gibson <address@hidden>
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
pgp6phTGReM2G.pgp
Description: PGP signature
- [Qemu-devel] [PATCH v2 09/11] vga: Make fb endian a common state variable, (continued)
- [Qemu-devel] [PATCH v2 09/11] vga: Make fb endian a common state variable, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.h, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 06/11] cirrus: Remove non-32bpp cursor drawing, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 04/11] vga: Remove rgb_to_pixel indirection, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 01/11] vga: Start cutting out non-32bpp conversion support, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 11/11] vga-pci: add qext region to mmio, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 02/11] vga: Remove remainder of old conversion cruft, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion functions, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 10/11] vga: Add endian control register, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 05/11] vga: Simplify vga_draw_blank() a bit, Gerd Hoffmann, 2014/09/29