[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.
From: |
Gerd Hoffmann |
Subject: |
[Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.h |
Date: |
Mon, 29 Sep 2014 11:31:09 +0200 |
From: Benjamin Herrenschmidt <address@hidden>
It's no longer a template, we only instanciate the file once.
Keep it a #included file so the functions remain static.
Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>
---
hw/display/{vga_template.h => vga-helpers.h} | 0
hw/display/vga.c | 2 +-
2 files changed, 1 insertion(+), 1 deletion(-)
rename hw/display/{vga_template.h => vga-helpers.h} (100%)
diff --git a/hw/display/vga_template.h b/hw/display/vga-helpers.h
similarity index 100%
rename from hw/display/vga_template.h
rename to hw/display/vga-helpers.h
diff --git a/hw/display/vga.c b/hw/display/vga.c
index 21aa2c6..9f60f88 100644
--- a/hw/display/vga.c
+++ b/hw/display/vga.c
@@ -1007,7 +1007,7 @@ void vga_mem_writeb(VGACommonState *s, hwaddr addr,
uint32_t val)
typedef void vga_draw_line_func(VGACommonState *s1, uint8_t *d,
const uint8_t *s, int width);
-#include "vga_template.h"
+#include "vga-helpers.h"
/* return true if the palette was modified */
static int update_palette16(VGACommonState *s)
--
1.8.3.1
- [Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 07/11] vga: Remove some "should be done in BIOS" comments, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 09/11] vga: Make fb endian a common state variable, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.h,
Gerd Hoffmann <=
- [Qemu-devel] [PATCH v2 06/11] cirrus: Remove non-32bpp cursor drawing, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 04/11] vga: Remove rgb_to_pixel indirection, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 01/11] vga: Start cutting out non-32bpp conversion support, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 11/11] vga-pci: add qext region to mmio, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 02/11] vga: Remove remainder of old conversion cruft, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion functions, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 10/11] vga: Add endian control register, Gerd Hoffmann, 2014/09/29