[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Compiling the CVS tree

From: Patrick Ale
Subject: [Qemu-devel] Compiling the CVS tree
Date: Tue, 9 Nov 2004 11:18:28 +0100


I did a checkout of the CVS repository.

On ./configure time I get this CSV as a result:

address@hidden:~/workspace/qemu/qemu$ ./configure --prefix=/usr/local/qemu
Install prefix    /usr/local/qemu
BIOS directory    /usr/local/qemu/share/qemu
binary directory  /usr/local/qemu/bin
Manual directory  /usr/local/qemu/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path       /home/patrick/workspace/qemu/qemu
C compiler        gcc
make              make
host CPU          i386
host big endian   no
target list       i386-user i386 i386-softmmu arm-user sparc-user ppc-user ppc-s
oftmmu sparc-softmmu
gprof enabled     no
static build      no
SDL support       yes
SDL static link   no
mingw32 support   no
WARNING: cannot compile statically with SDL - qemu-fast won't have a graphical o

Which was allright for me, I dont intend to use qemu-fast anyway.

But when I run make I get:
gcc  -static -Wl,-T,/home/patrick/workspace/qemu/qemu/i386-vl.ld  -o qemu-fast v
l.o osdep.o block.o readline.o monitor.o pci.o console.o block-cow.o block-qcow.
o aes.o block-vmdk.o block-cloop.o ide.o ne2000.o pckbd.o vga.o sb16.o dma.o aud
io.o ossaudio.o sdlaudio.o wavaudio.o fdc.o mc146818rtc.o serial.o i8259.o i8254
.o pc.o cirrus_vga.o mixeng.o gdbstub.o slirp/cksum.o slirp/if.o slirp/ip_icmp.o
slirp/ip_input.o slirp/ip_output.o slirp/slirp.o slirp/mbuf.o slirp/misc.o slir
p/sbuf.o slirp/socket.o slirp/tcp_input.o slirp/tcp_output.o slirp/tcp_subr.o sl
irp/tcp_timer.o slirp/udp.o slirp/bootp.o slirp/debug.o slirp/tftp.o libqemu.a
-lm -lz  -lutil
slirp/misc.o(.text+0x2a): In function `getouraddr':
/home/patrick/workspace/qemu/qemu/slirp/misc.c:96: warning: Using 'gethostbyname
' in statically linked applications requires at runtime the shared libraries fro
m the glibc version used for linking

Obviously I am missing something but I have no idea what shared
librarie I am missing. I run Debian/Testing. Does anyone have an idea
what addition deb package I need or what I have to compile manualy to
get QEMU into compiling?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]