[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Compiling the CVS tree

From: Jim C. Brown
Subject: Re: [Qemu-devel] Compiling the CVS tree
Date: Tue, 9 Nov 2004 08:20:37 -0500
User-agent: Mutt/1.4i

On Tue, Nov 09, 2004 at 11:18:28AM +0100, Patrick Ale wrote:
> Hi,
> I did a checkout of the CVS repository.
> On ./configure time I get this CSV as a result:
> WARNING: cannot compile statically with SDL - qemu-fast won't have a 
> graphical o
> utput
> Which was allright for me, I dont intend to use qemu-fast anyway.

Then you need to tell configure not to bother compiling qemu-fast. You
probably only want i386-softmmu. (This is in the FAQ so I won't repeat it here).

> But when I run make I get:
> gcc  -static -Wl,-T,/home/patrick/workspace/qemu/qemu/i386-vl.ld  -o 
> qemu-fast v
> l.o osdep.o block.o readline.o monitor.o pci.o console.o block-cow.o 
> block-qcow.
> o aes.o block-vmdk.o block-cloop.o ide.o ne2000.o pckbd.o vga.o sb16.o dma.o 
> aud
> io.o ossaudio.o sdlaudio.o wavaudio.o fdc.o mc146818rtc.o serial.o i8259.o 
> i8254
> .o pc.o cirrus_vga.o mixeng.o gdbstub.o slirp/cksum.o slirp/if.o 
> slirp/ip_icmp.o
> slirp/ip_input.o slirp/ip_output.o slirp/slirp.o slirp/mbuf.o slirp/misc.o 
> slir
> p/sbuf.o slirp/socket.o slirp/tcp_input.o slirp/tcp_output.o slirp/tcp_subr.o 
> sl
> irp/tcp_timer.o slirp/udp.o slirp/bootp.o slirp/debug.o slirp/tftp.o libqemu.a
> -lm -lz  -lutil
> slirp/misc.o(.text+0x2a): In function `getouraddr':
> /home/patrick/workspace/qemu/qemu/slirp/misc.c:96: warning: Using 
> 'gethostbyname
> ' in statically linked applications requires at runtime the shared libraries 
> fro
> m the glibc version used for linking
> Obviously I am missing something but I have no idea what shared
> librarie I am missing.

That would be /lib/libc.so.6 ... except that this is not missing. The message
is a warning (which is why it says "warning:") not an error. Does this actually
cause make to abort or something? Because it shouldn't. (I get this error too
when compiling qemu-fast but qemu-fast still works fine. It would just stop
working if I upgraded (or downgraded) glibc.)

> I run Debian/Testing. Does anyone have an idea
> what addition deb package I need or what I have to compile manualy to
> get QEMU into compiling?
> Cheers,
> Patrick
> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]