[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Keyboard problem in qemu 0.6.0-2

From: Bochnig, Martin
Subject: Re: [Qemu-devel] Keyboard problem in qemu 0.6.0-2
Date: Fri, 03 Sep 2004 19:13:42 +0200
User-agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1) Gecko/20030711

Kim Adil wrote:
I seem to have a default keymap to the french keyboard layout. I thought it must be defined in the guest os images that I downloaded, however, I tried booting a windows XP setup disk and the same key layout was experienced. Is there a way to alter this?


I have similar problems with a Solaris10_x86 host running QEMU 0.6.0 when displaying to the default Xsun X-Server at ':0.0' or forwarding to my SPARC machines running several Solaris versions.

These problems make QEMU (any Guest OS's command line, any input fields) completely unusable.

Almost exactly the same DISmapping appeared, when running the prebuilt 0.6.0 LinUX binary on the JDS1_Live Demo CD (while the mapping itself was different). Since no one else complained about it, my HOST and my machines displaying QEMU's window over the network appeared to be the cause.

Both the physical Keyboards itself (different vendors, different interfaces [ps/2 and usb]) as well as all guest and host OS's use US-English / POSIX C 7bit as default locale.

I had the same problem at University when running 0.6.0 on a Debian system installed in 2001.

On most of these systems
 is interpreted by the guest as
Many keys do nothing at all. Others give strange control seqences with their ascii hex id printed to the guest console.

I posted to the ml around a week ago but didn't get reports of others confirming my experiences. Am I the only one worldwide (your problem description still sounds quite moderate, as your keys are still in a usual sequential order - just shifted by a few keys) ?

WORKAROUND: First ensure that you have installed the very latest SDL release (unfortunately doing so didn't solve above problems in any way - however). ***The solution was to upgrade the HOST to the latest XFree86 4.x (that is to replace Xsun)*** ***Alternatively it may help to use VNC4.x (which actually uses/includes a minimal - XFree86 4.x server)***.
So the misbehavior seems to be Host-X11_Server dependent.
The key mappings between SDL<<--->>X11 seem to be the root of these errors.
A bug in qemu, as it doesn's support forwarding to proprietary or even free X11 servers, when too old.
(maybe an XFree86_4.x--only specific option not supported by anything else?)

Another alternative is: Go to http://www.dad-answers.com/qemu , download the NOsdl-patch, copy 'nosdl.c' over 'sdl.c' , type "make distclean;./configure;make" then switch user to root and do a make install.

Worked for me.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]