[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] ARM in big endian mode?

From: Lennert Buytenhek
Subject: Re: [Qemu-devel] ARM in big endian mode?
Date: Mon, 12 Jul 2004 01:43:27 +0200
User-agent: Mutt/1.4.1i

On Mon, Jul 12, 2004 at 12:17:27AM +0100, David Woodhouse wrote:

> > % ./qemu-arm ./x
> > qemu: uncaught target signal 11 (Segmentation fault) - exiting
> Are you sure that's happening only for BE ARM binaries? I have a vague
> recollection that last time I tried qemu-arm it was doing that even for
> LE executables.

Just checked, and indeed, LE binaries segfault too.

That's strange, since I remember checking LE ARM binaries a while ago,
and after patching qemu to correct some O_* flags (I think it had O_DIRECT
and O_DIRECTORY mixed up, or something like that), things seemed to work
okay.  I even built a small debian ARM chroot, fully emulated with qemu,
with an sshd running in there, etc.

So it looks like it (might have) worked in the past but broke somewhere
between then and now.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]