[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] OS/2 Warp sound issues and patch (?)

From: Johannes Martin
Subject: [Qemu-devel] OS/2 Warp sound issues and patch (?)
Date: Sun, 11 Jul 2004 19:02:10 +0200 (CEST)


I just compiled qemu from cvs on a Debian Linux system. Then I tried to
install OS/2 Warp 4. The install worked fine except that I got a
segmenation fault during network install, so my final OS/2 installation
does not have any network drivers installed, but that's another issue...

qemu crashed pretty predictably whenever I tried to open a folder and for
some other system events that caused sound output (I use qemu with
-enable-audio). I got an error message saying:
        oss: write audio
        system error: Unknown error 572
(the error number would change)

I found the place in oss.c that causes the abort and tried to fix it. The
patch below works fine for me: sound continues to work and I no longer get
any aborts (just the occasional error message on the console).

Another issue: when qemu aborts, I sometimes lose my mouse pointer.
Restarting qemu fixes that problem. Maybe qemu should clean up a little
bit before aborting, such as resetting mouse and terminal.

Great work! I'm impressed.


*** oss.c       Sun Jul 11 18:02:19 2004
--- oss.c.~1.5.~        Mon Jul  5 23:25:11 2004
*** 410,420 ****
              else {
!                 int _errno = errno;
!                 fprintf (stderr, "oss: write audio\n");
!                 fprintf (stderr, "system error: %s\n", strerror (_errno));
!                 // ERRFail ("write audio");
!                 written = play;

--- 410,416 ----
              else {
!                 ERRFail ("write audio");

reply via email to

[Prev in Thread] Current Thread [Next in Thread]