qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] freeoszoo and mandrake linux


From: Mark Huot
Subject: [Qemu-devel] freeoszoo and mandrake linux
Date: Wed, 07 Jul 2004 16:04:49 -0400

does anyone know why the mandrake linux img from the freeoszoo won't work?

On Jul 7, 2004, at 4:01 PM, Tomasz B±tor wrote:

Witam,
Dnia Wed, Jul 07, 2004 at 09:50:17PM +0200 Jernej Simon?i? napisal(a):

I successfully compiled CVS under msys/MinGW and ran it outside it, however
before compiling I edited CONFIG_QEMU_SHAREDIR in config-host.h to "."
(otherwise it's set to $prefix, which is by default "/c/Program
Files/Qemu"). If you remove -mwindows from CFLAGS and run qemu from command line, you can usually see why it immediately exits (though the very latest
CVS doesn't seem to output anything anymore)

I solved that immediate exit without output by applying
qemu-20040621-monitor.patch.gz and changing manually LIBS in i386-softmmu/Makefile
(I only compile i386-softmmu), so it looks like:

DEFINES+=-D_GNU_SOURCE
LIBS+=-lm
ifdef CONFIG_WIN32
LIBS+=-lwinmm -lws2_32 -liphlpapi -mconsole
endif

After that, the console in windows is back.

t.

--
  Tomasz Bątor  e-mail: address@hidden  ICQ: 101194886
 ------ ---- -- - -  -    -   -  -  -   -    -  - - -- ---- ------
"Today it's a race between programmers making better idiot proof software,
and the universe making better idiots. So far the universe is winning"


_______________________________________________
Qemu-devel mailing list
address@hidden
http://lists.nongnu.org/mailman/listinfo/qemu-devel





reply via email to

[Prev in Thread] Current Thread [Next in Thread]