qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 32/46] qom: Rename qdev_get_type() to object_get_type()


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 32/46] qom: Rename qdev_get_type() to object_get_type()
Date: Thu, 25 Jun 2020 08:33:03 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 6/24/20 6:43 PM, Markus Armbruster wrote:
> Commit 2f262e06f0 lifted qdev_get_type() from qdev to object without
> renaming it accordingly.  Do that now.
> 
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>  qom/object.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/qom/object.c b/qom/object.c
> index b8aac074c2..f6e9f0e413 100644
> --- a/qom/object.c
> +++ b/qom/object.c
> @@ -2359,7 +2359,7 @@ object_class_property_add_tm(ObjectClass *klass, const 
> char *name,
>                                       NULL, NULL, prop);
>  }
>  
> -static char *qdev_get_type(Object *obj, Error **errp)
> +static char *object_get_type(Object *obj, Error **errp)
>  {
>      return g_strdup(object_get_typename(obj));
>  }
> @@ -2702,7 +2702,7 @@ void object_class_property_set_description(ObjectClass 
> *klass,
>  
>  static void object_class_init(ObjectClass *klass, void *data)
>  {
> -    object_class_property_add_str(klass, "type", qdev_get_type,
> +    object_class_property_add_str(klass, "type", object_get_type,
>                                    NULL);
>  }
>  
> 

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]