[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-arm] qemu-system-arm with GPU support for QT with OpenGL on

From: Andy Ng
Subject: Re: [Qemu-arm] qemu-system-arm with GPU support for QT with OpenGL on
Date: Sun, 5 May 2019 18:46:34 +0100

Thank you for the reply.

I have seen the link you mentioned, I just try to reproduce the same
thing. I am using gemu 4.0  I have the following config:

Install prefix    /usr/local
BIOS directory    /usr/local/share/qemu
firmware path     /usr/local/share/qemu-firmware
binary directory  /usr/local/bin
library directory /usr/local/lib
module directory  /usr/local/lib/qemu
libexec directory /usr/local/libexec
include directory /usr/local/include
config directory  /usr/local/etc
local state directory   /usr/local/var
Manual directory  /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path       /opt/linux-arm-qemu-versatile/qemu-4.0.0
GIT binary        git
GIT submodules
C compiler        cc
Host C compiler   cc
C++ compiler      c++
Objective-C compiler cc
ARFLAGS           rv
QEMU_CFLAGS       -I/usr/include/pixman-1 -I$(SRC_PATH)/dtc/libfdt
-pthread -I/usr/include/glib-2.0
-I/usr/lib/x86_64-linux-gnu/glib-2.0/include -fPIE -DPIE -m64 -mcx16
-Wstrict-prototypes -Wredundant-decls -Wall -Wundef -Wwrite-strings
-Wmissing-prototypes -fno-strict-aliasing -fno-common -fwrapv
-std=gnu99  -Wendif-labels -Wno-missing-include-dirs -Wempty-body
-Wnested-externs -Wformat-security -Wformat-y2k -Winit-self
-Wignored-qualifiers -Wold-style-declaration -Wold-style-definition
-Wtype-limits -fstack-protector-strong  -I/usr/include/libpng12
LDFLAGS           -Wl,--warn-common -Wl,-z,relro -Wl,-z,now -pie -m64 -g
QEMU_LDFLAGS      -L$(BUILD_DIR)/dtc/libfdt
make              make
install           install
python            python -B (2.7.12)
slirp support     internal
smbd              /usr/sbin/smbd
module support    no
host CPU          x86_64
host big endian   no
target list       arm-softmmu aarch64-softmmu
gprof enabled     no
sparse enabled    no
strip binaries    yes
profiler          no
static build      no
SDL support       yes (2.0.4)
SDL image support no
GTK support       yes (3.18.9)
GTK GL support    yes
VTE support       no
TLS priority      NORMAL
GNUTLS support    no
libgcrypt         no
nettle            yes (3.2)
libtasn1          no
PAM               no
iconv support     yes
curses support    no
virgl support     yes (0.6.0)
curl support      no
mingw32 support   no
Audio drivers     pa oss
Block whitelist (rw)
Block whitelist (ro)
VirtFS support    no
Multipath support no
VNC support       yes
VNC SASL support  no
VNC JPEG support  no
VNC PNG support   yes
xen support       no
brlapi support    no
bluez  support    no
Documentation     no
PIE               yes
vde support       no
netmap support    no
Linux AIO support no
ATTR/XATTR support yes
Install blobs     yes
KVM support       yes
HAX support       no
HVF support       no
WHPX support      no
TCG support       yes
TCG debug enabled no
TCG interpreter   no
malloc trim support yes
RDMA support      no
PVRDMA support    no
fdt support       git
membarrier        no
preadv support    yes
fdatasync         yes
madvise           yes
posix_madvise     yes
posix_memalign    yes
libcap-ng support no
vhost-net support yes
vhost-crypto support yes
vhost-scsi support yes
vhost-vsock support yes
vhost-user support yes
Trace backends    log
spice support     no
rbd support       no
xfsctl support    no
smartcard support no
libusb            no
usb net redir     no
OpenGL support    yes
OpenGL dmabufs    yes
libiscsi support  no
libnfs support    no
build guest agent yes
QGA VSS support   no
QGA w32 disk info no
QGA MSI support   no
seccomp support   no
coroutine backend ucontext
coroutine pool    yes
debug stack usage no
mutex debugging   no
crypto afalg      no
GlusterFS support no
gcov              gcov
gcov enabled      no
TPM support       yes
libssh2 support   no
TPM passthrough
TPM emulator
QOM debugging     yes
Live block migration yes
lzo support       no
snappy support    no
bzip2 support     no
lzfse support     no
NUMA host support no
libxml2           no
tcmalloc support  no
jemalloc support  no
avx2 optimization yes
replication support yes
VxHS block device no
bochs support     yes
cloop support     yes
dmg support       yes
qcow v1 support   yes
vdi support       yes
vvfat support     yes
qed support       yes
parallels support yes
sheepdog support  yes
capstone          internal
docker            no
libpmem support   no
libudev           yes
default devices   yes

I tried :

sudo qemu-system-arm -m 1024M -M virt -drive
if=none,file=OSMC_TGT_rbp2_20190424.img,id=hd0 -device
virtio-blk-device,drive=hd0 -netdev type=tap,id=net0 -device
virtio-net-device,netdev=net0 -device virtio-gpu -display gtk,gl=on

But I get the error "Guest has not initialised the display (yet)"

Not sure what may be going wrong.. I am still investigating.

Thank you

On Sun, May 5, 2019 at 4:31 PM Peter Maydell <address@hidden> wrote:
> On Sat, 4 May 2019 at 21:42, Andy Ng <address@hidden> wrote:
> > I have tried to create Cortex-A9 images based on vexpress, however
> > qemu will complain about the PCI. I have tried to use -M virt, but
> > this one brings up cortex-A15, compatibility issue.
> >
> > Any ideas what would it be the best way forward to make it run on
> > Qemu?   Do you know what is the best -M type that I have to use.
> Our recommendation is to use "virt":
> https://wiki.qemu.org/Documentation/Platforms/ARM#Guidelines_for_choosing_a_QEMU_machine
> > realview-pbx-a9 ? I do not want to recompile the code in different
> > architecture of CPU model.
> Cortex-A9 and -A15 are very close -- any application level
> code built for the A9 should run fine on QEMU's A15 model.
> The kernel will obviously need to be built with "virt" board
> support and Cortex-A15 support enabled, but you need to
> build a kernel that works for the board model you select anyway.
> thanks
> -- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]