[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-arm] Ubuntu installation shows "No network interfaces detected

From: Da Zhang
Subject: Re: [Qemu-arm] Ubuntu installation shows "No network interfaces detected"
Date: Tue, 16 Apr 2019 11:33:09 -0400

This is my gem5 simulation output. My goal is using qemu-system-aarch64 to create an ARM disk image for my gem5 simulations, since qemu provides a better solution to modify the image (e.g., apt-get install) for different purposes.

Firstly, I created a qcow2 image and used the qemu-system-aarch64 command shown in the previous emails to install Ubuntu. 
Secondly, I converted the qcow2 disk image to raw format and rebooted from the raw disk image via qemu-system-aarch64 (without cdrom) again to make sure the Ubuntu system work. 
Thirdly, I put gem5's m5 executable in the guest system's /sbin/ and create gem5.service, and reran qemu to make sure the disk image still work after modifications. 
Finally, I ran my gem5 simulation using the disk image and encountered the kernel panic. The linux kernel used in my gem5 simulation was built from repository "https://gem5.googlesource.com/arm/linux" branch gem5/v4.4 for linux kernel version 4.4.

I am not sure if gem5 support vda or not. Since both our X86 disk image and the official ARM disk image used sda, I thought I might give it a quick try. That's why I asked how to run qemu-system-aarch64 with sda. I tried -hda and -cdrom, but qemu-system-aarch64 didn't recognize the disk image and the iso. I also tried to use device like scsi-hd, but qemu complained about no SCSI bus.


On Tue, Apr 16, 2019 at 10:47 AM Peter Maydell <address@hidden> wrote:
On Tue, 16 Apr 2019 at 15:24, Da Zhang <address@hidden> wrote:

This seems to be missing some output from the start of boot.

> [    2.361820] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
> [    2.375346] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.4.0-k
> [    2.390986] igb: Copyright (c) 2007-2014 Intel Corporation.
> [    2.403596] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 5.1.0-k
> [    2.420739] ixgbe: Copyright (c) 1999-2016 Intel Corporation.
> [    2.437883] ixgbevf: Intel(R) 10 Gigabit PCI Express Virtual Function Network Driver - version 4.1.0-k

> [    2.642190] usbcore: registered new interface driver usbhid
> [    2.642191] usbhid: USB HID core driver
> [    2.642322] NET: Registered protocol family 17
> [    2.916496] scsi 0:0:0:0: Direct-Access     ATA      M5 IDE Disk      n/a  PQ: 0 ANSI: 5
> [    2.935127] sd 0:0:0:0: [sda] 16777216 512-byte logical blocks: (8.59 GB/8.00 GiB)
> [    2.952327] sd 0:0:0:0: Attached scsi generic sg0 type 0
> [    2.964648] sd 0:0:0:0: [sda] Write Protect is off
> [    2.975518] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
> [    2.986957] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
> [    3.101444]  sda: sda1 sda2 sda3
> [    3.109804] sd 0:0:0:0: [sda] Attached SCSI disk
> [    3.452824] VFS: Mounted root (vfat filesystem) on device 8:1.

We found and mounted the ISO image's VFAT partition...

> [    3.466085] devtmpfs: error mounting -2
> [    3.475091] Freeing unused kernel memory: 384K
> [    3.485519] Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.

...but unsurprisingly that is not a workable root filesystem.

> [    3.516805] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.14.0+ #2
> [    3.530257] Hardware name: V2P-CA15 (DT)
> [    3.539161] Call trace:
> [    3.544930] [<ffffff8008088250>] dump_backtrace+0x0/0x370
> [    3.557065] [<ffffff80080885d4>] show_stack+0x14/0x20
> [    3.568513] [<ffffff800863ffe8>] dump_stack+0x8c/0xac
> [    3.579903] [<ffffff80080b7338>] panic+0x11c/0x274
> [    3.590712] [<ffffff8008652244>] kernel_init+0xec/0x100
> [    3.602463] [<ffffff8008084348>] ret_from_fork+0x10/0x18
> [    3.614433] Kernel Offset: disabled
> [    3.622386] CPU features: 0x002000
> [    3.630153] Memory Limit: 1024 MB
> [    3.637726] ---[ end Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.
> This is my ARM/gem5.fast simulation output. The following is my gem5 command:
> build/ARM/gem5.fast --listener-mode=on -d /home/rock64/tmp/arm_ configs/example/fs.py --machine-type=VExpress_GEM5_V1 --kernel=vmlinux.arm.4.4 --disk-image=ubuntu-16.04.5-server-arm64.img --mem-size=1GB --cpu-type=ArmV8KvmCPU --generate-dtb -n 1

Wait, are you running this on QEMU or on GEM5?

Anyway, the lack of anything virtio related in the output you
quote leads me to suggest you check that your guest kernel
config has all the virtio devices in it. You might as well
add in PCI too (you want CONFIG_PCI, CONFIG_VIRTIO_PCI,

Also, have you actually managed to do an install onto the
hard disk image yet? If not, then something is going wrong
before here that it's not doing an install properly.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]