[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Aspirin 2.2 - system dont initialize

From: Piotr Esden-Tempski
Subject: Re: [Paparazzi-devel] Aspirin 2.2 - system dont initialize
Date: Fri, 7 Dec 2012 15:10:34 -0800

You need to use newest drivers in master branch. As the chip select for the 
MS5611 has to be high (disabled) if you want to communicate with the MPU-6000. 
Otherwise the barometer thinks it is active and will interfere with the 
communication to the MPU-6000.

Cheers Piotr

On Dec 7, 2012, at 3:03 PM, Michal Podhradsky <address@hidden> wrote:

> Hi guys,
> I recently got new Lia (Lisa M 2.0) boards with Aspirin IMU v.2.2 from 
> Transition Robotics. I tried to use the same drivers as for Aspirin v.2.1, 
> however in the standard configuration the system dont initialize and only 
> CPU_LED is flashing. No activity on UART ports and other peripherals, no 
> telemetry.
> I tried to use Aspirin with NO_SLAVES option (because now the barometer is 
> moved on SPI bus), and then the system starts, however I am not getting any 
> reading from IMU (not even acceleration or gyro).
> I tested it with Paparazzi v.4.0.3 (current stable) and 4.9 (master), but the 
> effect was the same.
> Seems to be a bug, maybe in the drivers? 
> I used the default config file (Quad_LisaM_2)  
> airframes/examples/quadrotor_lisa_m_2_pwm_spektrum.xml
> Just a note, these drivers were working with Aspirin 2.1 (expect of pressure 
> data, of course).
> Any idea how to fix the issue?
> Cheers
> Michal
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]