[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Aspirin 2.2 - system dont initialize

From: Michal Podhradsky
Subject: [Paparazzi-devel] Aspirin 2.2 - system dont initialize
Date: Fri, 7 Dec 2012 16:03:00 -0700

Hi guys,

I recently got new Lia (Lisa M 2.0) boards with Aspirin IMU v.2.2 from Transition Robotics. I tried to use the same drivers as for Aspirin v.2.1, however in the standard configuration the system dont initialize and only CPU_LED is flashing. No activity on UART ports and other peripherals, no telemetry.

I tried to use Aspirin with NO_SLAVES option (because now the barometer is moved on SPI bus), and then the system starts, however I am not getting any reading from IMU (not even acceleration or gyro).

I tested it with Paparazzi v.4.0.3 (current stable) and 4.9 (master), but the effect was the same.

Seems to be a bug, maybe in the drivers?

I used the default config file (Quad_LisaM_2)  airframes/examples/quadrotor_lisa_m_2_pwm_spektrum.xml

Just a note, these drivers were working with Aspirin 2.1 (expect of pressure data, of course).

Any idea how to fix the issue?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]