[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build issues

From: Joseph Cossette
Subject: Re: Build issues
Date: Mon, 24 Jul 2023 15:45:57 +0000



I created a VM from standard desktop Ubuntu 22.04.2 LTS .iso file.  Added build essentials and some other tools for development, as well as any other noted dependencies for oath toolkit (Linux pam headers, libxml2, etc.,…).


Used the following command line to configure:


/configure --prefix=$PWD/../built --enable-pskc


Configure ends with the following lines, which show that pskc would not be built:


  version:          2.6.9

  Install prefix:   /mnt/hgfs/snc2/third_party/oath/oath-toolkit-2.6.9/../built

  Compiler:         gcc

  Build PAM module: yes

  PSKC:             no


I’ve attached the config.log & config.status file for your perusal.  In searching for XML2 in the config log file it appears to indicate that it didn’t find it, even though it is installed on the system.  It then of course doesn’t even attempt to build any pskc artifacts, as where if it at least configured for pskc artifacts the resolution could then be deferred to compilation/linking steps, which is typically easier to handle for embedded systems.


As I previously mentioned, oathtool and it’s dependent library liboath appear to be building correctly for both Ubuntu and Yocto ARM.  But whenever we try to build the pskc artifacts by enabling them to configure, we basically get the same thing on both systems…namely, configure appears to not find the libxml2 artifacts. No pskc artifacts, only oath artifacts get produced.  Our Yocto build is also not building the pam module.  Since we’re also building the kernel in the Yocto sandbox it successfully builds all other pams though.


I’m sure if we put more man hours into it we could come up with a custom CMake build for this package within our Yocto sandbox, but we would much prefer to use your standard build so as to be able to get any timely security fixes and testcases.  But since it appeared that there may be a build problem with the package even using a popular standard desktop Linux,  I thought we’d wait before we spin any more resources and see if you folks had any ideas before we proceeded further.


Any help in getting this built using your standard build package would be greatly appreciated.


Thanks in advance.





On 7/21/23, 7:35 PM, "Simon Josefsson" <simon@josefsson.org> wrote:

Hi Joseph,


Thanks for your interest.  Can you be specific about what your build

problems are?  Explaining how you tried to build the package, and what

error message you got will help.


OATH Toolkit is built continously in GitLab CI/CD:



The latest release 2.6.9 builds in many environments:



I maintain the Debian packages for it, which are also updated and

appears to build on all architectures:



Including cross-builds:





Joseph Cossette <joseph.cossette@jci.com> writes:


> We’d like to use the oath toolkit for 2FA on our new embedded device,

> but we’re having issues trying to get it all built under Yocto (or

> Ubuntu 22.04 desktop for that matter).


> We’re able to get oathtool and liboath built (and on Ubuntu also the pam).


> But pskctool and libpskc refuse to be configured.  After examination

> it appears that XML2 may be the cause of the problem (even under

> Ubuntu).  XML2 is installed in Yocto (and Ubuntu), but the configure

> check for the package always fails, so it’s not being included in the

> makefiles (on both platforms).


> I did a bit of searching and saw that a 2-year old merge ticket on

> XML2 was put in by folks here…it mentions 2.70+…we’re using 2.9.x

> versions…but configure still doesn’t find them.


> It appears (for all practical purposes), the oath toolkit configure

> procedure is broken…likely on many systems too if it can’t even be

> built out of the box on Ubuntu 22.04.


> Not sure where to go from here on this.  We’ve already put in quite a

> few man hours into trying to get this built and have stopped trying at

> this point…it’s burning up too much resources…;(…


> If anyone has any information on how to resolve this issue please reply.


Attachment: config.log
Description: config.log

Attachment: config.status
Description: config.status

reply via email to

[Prev in Thread] Current Thread [Next in Thread]