[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build issues

From: Simon Josefsson
Subject: Re: Build issues
Date: Sat, 22 Jul 2023 01:34:38 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux)

Hi Joseph,

Thanks for your interest.  Can you be specific about what your build
problems are?  Explaining how you tried to build the package, and what
error message you got will help.

OATH Toolkit is built continously in GitLab CI/CD:


The latest release 2.6.9 builds in many environments:


I maintain the Debian packages for it, which are also updated and
appears to build on all architectures:


Including cross-builds:



Joseph Cossette <joseph.cossette@jci.com> writes:

> We’d like to use the oath toolkit for 2FA on our new embedded device,
> but we’re having issues trying to get it all built under Yocto (or
> Ubuntu 22.04 desktop for that matter).
> We’re able to get oathtool and liboath built (and on Ubuntu also the pam).
> But pskctool and libpskc refuse to be configured.  After examination
> it appears that XML2 may be the cause of the problem (even under
> Ubuntu).  XML2 is installed in Yocto (and Ubuntu), but the configure
> check for the package always fails, so it’s not being included in the
> makefiles (on both platforms).
> I did a bit of searching and saw that a 2-year old merge ticket on
> XML2 was put in by folks here…it mentions 2.70+…we’re using 2.9.x
> versions…but configure still doesn’t find them.
> It appears (for all practical purposes), the oath toolkit configure
> procedure is broken…likely on many systems too if it can’t even be
> built out of the box on Ubuntu 22.04.
> Not sure where to go from here on this.  We’ve already put in quite a
> few man hours into trying to get this built and have stopped trying at
> this point…it’s burning up too much resources…;(…
> If anyone has any information on how to resolve this issue please reply.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]