[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Nano-devel] "Bus error" when searching in nano - gdb backtraces attache

From: Hans Ecke
Subject: [Nano-devel] "Bus error" when searching in nano - gdb backtraces attached
Date: Mon, 30 Oct 2006 15:09:28 -0700 (MST)


I'm on Suse 10.1 x86-64 with all the supplementary and mainstream updates 
applied. I just compiled nano 1.9.99-pre3.
   gcc 4.02
   glib 1.2.10, glib2 2.8.5 (I understand you use glib code somewhere?)
   glibc 2.8.5
   kernel 2.6.13
   ncurses 5.4

When I start nano and do the following:
   * type a bunch of stuff on a couple lines
   * search for one of the strings I just typed
I get the message "Bus error" and nano crashes.


Attached are three gdb backtraces from the core files. 

Next I tried it running under valgrind and it worked just fine. Thats 

I have been getting the same error with nano 1.3.8 (which is the version 
that comes with Suse these days, I think) and I hoped 1.9.99 would fix it. 
No such luck...



Hans Ecke              R&D Geophysicist
address@hidden      GX Technology, AXIS Imaging division
(USA) 303-625-2203     Denver, Colorado

"Once they go up, who cares where they come down?  That's not my department."
                    -- Werner von Braun
This email and any files transmitted with it are confidential and are intended 
solely for the use of the individual or entity to whom they are addressed.  If 
you are not the original recipient or the person responsible for delivering the 
email to the intended recipient, be advised that you have received this email 
in error, and that any use, dissemination, forwarding, printing, or copying of 
this email is strictly prohibited. If you received this email in error, please 
immediately notify the sender and delete the original.

Attachment: nano-gdb-1.txt
Description: Text document

Attachment: nano-gdb-2.txt
Description: Text document

Attachment: nano-gdb-3.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]