[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] "Bus error" when searching in nano - gdb backtraces att

From: David Lawrence Ramsey
Subject: Re: [Nano-devel] "Bus error" when searching in nano - gdb backtraces attached
Date: Mon, 30 Oct 2006 22:41:53 -0500
User-agent: Thunderbird (X11/20060909)

Hans Ecke wrote:


> I'm on Suse 10.1 x86-64 with all the supplementary and mainstream
> updates applied. I just compiled nano 1.9.99-pre3.
> > gcc 4.02
>    glib 1.2.10, glib2 2.8.5 (I understand you use glib code somewhere?)

glib 2.x is only used if your C library lacks vsnprintf(), and, if
you're using glibc, it shouldn't.

>    glibc 2.8.5

This looks like a typo, as the latest version of glibc is 2.4.

>    kernel 2.6.13
>    ncurses 5.4
> When I start nano and do the following:
>    * type a bunch of stuff on a couple lines
>    * search for one of the strings I just typed
> I get the message "Bus error" and nano crashes.
>    TERM=xterm
>    LANG=en_US.UTF-8
> Attached are three gdb backtraces from the core files.

Thanks for all the info.  It's definitely useful.  However, there is
also some useful information left out, as shown by "No symbol table info
available." and "<variable optimized out>".  Would you mind recompiling
1.9.99pre3 with just the "-g3" flag, not stripping the binary, and
generating another backtrace from that version?  Thanks in advance.

> Next I tried it running under valgrind and it worked just fine. Thats
> puzzling.
> I have been getting the same error with nano 1.3.8 (which is the
> version that comes with Suse these days, I think) and I hoped 1.9.99
> would fix it. No such luck...

Not much luck here either, unfortunately.  I can't test this myself
because I no longer have access to any 64-bit machines and/or machines
running Suse; I don't have gcc 4.0.2; and if I did have gcc 4.0.2, I'd
have to recompile much of my system, since I'm using 3.4.6 right now.

From your gdb traces, which show that it's originally crashing in
malloc(), to your report that it's crashing after searches, it sounds
exectly like this bug from Gentoo (in it, see comments 7 and 16, and
especially comments 78 and 79), which affects nano, but is actually in

The only problem is that this bug is fixed in the glibc source RPM for
Suse 10.1 (version 2.4-25), according to the included spec file, so it
shouldn't be occurring at all.  Or are you using version 2.4-25?

> Thanks!

No problem.  I hope I can be of some help...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]