[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] Monitoring with ICMP

From: Derek
Subject: Re: [monit] Monitoring with ICMP
Date: Tue, 23 Mar 2010 15:18:37 +1300
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20100227 Thunderbird/3.0.3

Hi Martin,

Sure I have attached the monitrc file here.  Yes sure the host was down (VPS virtual network dropped), i've tried several known-dead IP's with the same result, hopefully something silly i've done in the config

Thanks for your help

On 23/03/10 2:14 PM, Martin Pala wrote:
This is very strange - monit ICMP echo (ping) check tests unique id sequence number - unless it get correct response it cannot report false positive response. 

Are you sure that the host was down at the time when monit icmp echo test succeeded? Can you provide monit configuration from the host which reported false positive?


On Mar 22, 2010, at 8:16 AM, Derek wrote:

Hi All,

First of all great work monit has come in very handy in our environment.

Just found a server had gone offline in our environment today and we did not get an alert.  We only had an ICMP 'check host' for it's IP in this case, the networking failed and it slipped through our monitoring.

I can't seem to see why and I can recreate the issue with other IP's/networks, can any one comment or see an issue with the below?

check host xx.xx.xx.xx with address xx.xx.xx.xx
if failed icmp type echo with timeout 4 seconds then alert

/usr/sbin/monit -V
This is monit version 4.10.1

Debian Lenny 5.0 and the standard repository package

I can appreciate there may be other variables involved that could cause this but it seems to be the only check monit performs that I have seen get missed like this.

Your help is much appreciated


To unsubscribe:

Attachment: monitrc.rtf
Description: RTF file

reply via email to

[Prev in Thread] Current Thread [Next in Thread]