[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mingw-cross-env-list] Moving MXE directory

From: Arthur Toussaint
Subject: [Mingw-cross-env-list] Moving MXE directory
Date: Wed, 25 Jun 2014 11:00:13 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0


I'm trying to cross-compile a Qt app using mxe, I've managed to build it
on my desktop environment, but now I'm trying to build on a CI
environment, the problem is that if I rebuild the mxe environment at
each commit, the build on the CI environment is too long (>1h), so I
decided to make a tarball with the mxe I built on my desktop environment
and download it on the CI.

The problem is that when I do a qmake, I get "QMAKESPEC has not been
set, so configuration cannot be deduced". So I set QMAKESPEC to
<mxe_path>/usr/i686-w64-mingw32.shared/qt/mkspecs/win32-g++ and the
qmake worked, but when I try to make, I get "fatal error: QString: No
such file or directory".

I think it is a weird path problem or somthing like that, but I really
don't know where the problem is. I tried to move the mxe folder in my
desktop environment and I got the same problem

Thanks in advance for your help

reply via email to

[Prev in Thread] Current Thread [Next in Thread]