[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] Moving MXE directory

From: Arthur Toussaint
Subject: Re: [Mingw-cross-env-list] Moving MXE directory
Date: Thu, 26 Jun 2014 21:31:08 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

Ok, and isn't there any way to specify the path before build (Like an
argument or an env variable) ? Or do I have to create the folder and
build everything inside that folder

Le 25/06/14 16:14, Martin Gerhardy a écrit :
> hi
> you can not do that easily because the (absolute) paths are compiled into 
> some binaries, pkg files and most likely a lot of other files. you have to 
> rebuild them on your desktop with the same paths the ci env is using. then 
> you should be able to copy it. but they have to exactly match.
> martin
> Am 25.06.2014 um 11:00 schrieb Arthur Toussaint <address@hidden>:
>> Hello,
>> I'm trying to cross-compile a Qt app using mxe, I've managed to build it
>> on my desktop environment, but now I'm trying to build on a CI
>> environment, the problem is that if I rebuild the mxe environment at
>> each commit, the build on the CI environment is too long (>1h), so I
>> decided to make a tarball with the mxe I built on my desktop environment
>> and download it on the CI.
>> The problem is that when I do a qmake, I get "QMAKESPEC has not been
>> set, so configuration cannot be deduced". So I set QMAKESPEC to
>> <mxe_path>/usr/i686-w64-mingw32.shared/qt/mkspecs/win32-g++ and the
>> qmake worked, but when I try to make, I get "fatal error: QString: No
>> such file or directory".
>> I think it is a weird path problem or somthing like that, but I really
>> don't know where the problem is. I tried to move the mxe folder in my
>> desktop environment and I got the same problem
>> Thanks in advance for your help

reply via email to

[Prev in Thread] Current Thread [Next in Thread]