maposmatic-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Maposmatic-dev] Modernize MapOSMatic


From: Hartmut Holzgraefe
Subject: Re: [Maposmatic-dev] Modernize MapOSMatic
Date: Fri, 11 Nov 2016 14:07:31 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0

On 11.11.2016 13:19, √Čtienne Loks wrote:

> I have not yet tested with your work. Have you introduced new
> dependencies?

python-rsvg (via apt) and colour (via pip). rsvg is needed to
show the SVG version of the OSM logo instead of the bitmap one,
and for the extra compass rose image, colour is only needed in
the alternative indexer that I added.

I also tried with a fresh checkout of your ocitysmap repo only,
without any of my changes applied -> same result

> The main difference with your dependency list is that I am
> installing CartoOSM with the deb package (wonderful Debian!).

The styles are taken from github on purpose as I wanted to
have them as current as possible. Until recently I used
Ubuntu 16.04 as base image, and that comes with version 2.37.1
of the CartoOSM style. 16.10 is at 2.42.0, so a bit closer,
but still behind upstream CartoOSM which is at 2.44.1 right now

> The missing fonts for your vagrant conf should be listed here:
> 
> https://packages.debian.org/stretch/openstreetmap-carto-common
> 
> Regards,

All of these are installed by now, no difference ...

What indeed makes a difference though is the CartoOSM version.
v2.42.0 works, 2.43.0 and 2.44.x don't ... will try to track
down the actual changeset that causes this later ...




reply via email to

[Prev in Thread] Current Thread [Next in Thread]