[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] How to use multi-bookmarks? (What am I doing wrong?)

From: David Combs
Subject: [Lynx-dev] How to use multi-bookmarks? (What am I doing wrong?)
Date: Thu, 21 Apr 2005 18:55:31 -0400
User-agent: Mutt/

First, here's a bit of doc on it:

          Lynx supports a default bookmark file, and up to 26 total
          bookmark files (see below). When multi-bookmarks is OFF, the
          default bookmark file is used for the 'v'iew bookmarks and
          'a'dd bookmark link commands. If multi-bookmark support is
          available in your account, the setting can be changed to
          STANDARD or ADVANCED. In STANDARD mode, a menu of available
          bookmarks always is invoked when you seek to view a bookmark
          file or add a link, and you select the bookmark file by its
          letter token (see Bookmark file, below) in that menu. In
          ADVANCED mode, you instead are prompted for the letter of the
          desired bookmark file, but can enter '=' to invoke the
          STANDARD selection menu, or RETURN for the default bookmark

   Bookmark file
          When multi-bookmarks is OFF, this is the filename and location
          of your default personal bookmark file. Enter 'B' to modify
          the filename and/or location via the [71]Line Editor. Bookmark
          files allow frequently traveled links to be stored in personal
          easy to access files. Using the 'a'dd bookmark link command
          (see [72]Lynx bookmarks) you may save any link that does not
          have associated POST content into a bookmark file. All
          bookmark files must be in or under your account's home
          directory. If the location specified does not begin with a
          dot-slash (./), its presence will still be assumed, and
          referenced to the home directory. When multi-bookmarks is
          STANDARD or ADVANCED, entering 'B' will invoke a menu of up to
          26 bookmark files (associated with the letters of the English
          alphabet), for editing their filenames and locations
          (filepath), and descriptions. Lynx will create bookmark files,
          if they don't already exist, when you first 'a'dd a bookmark
          link to them. However, if you've specified a subdirectory
          (e.g., ./BM/lynx_bookmarks.html), that subdirectory must
          already exist. Note that on VMS you should use the URL syntax
          for the filepath (e.g., not [.BM]lynx_bookmarks.html). For
          Win32, see [???].

------------------FYI: here's how I run lynx -- via the alias testlynx:

> alias testlynx
lynx   -cfg=~/lynx.cfg   -useragent="Lynx 2.8.4rel.1" -vikeys -cache=60 -book

And, here's the "=" page:

              Lynx 2.8.5rel.1 (04 Feb 2004) ([1]latest release)

-------------------------------- File that you are currently viewing:

   Linkname: Bookmark Page
        URL: file://localhost/net/u/1/d/dkcombs/lynx_bookmarks.html
    Charset: iso-8859-1 (assumed)
   Content-Length: 591463 bytes
   Owner(s): None
       size: 11979 lines
       mode: normal, bookmark file

Link that you currently have selected

   Linkname: Goodlight Message Board

(1) I tried to set multi-bookmarks to standard, via the options
    menu, and then "clicked" on accept changes -- and tried
    rerunning lynx.  That option-menu still showed off.

(2) So, I changed it in .lynxrc, to "standard".  Then I ran

(This being the bookmark-section of the Options-page
I see having by-hand changed .lynxrc:

  Special Files and Screens
  Multi-bookmarks                  : [36][(2)__STANDARD]
  Review/edit Bookmarks files      : [37]Goto multi-bookmark menu
  Visited Pages                    : [38][(3)__As Visit Tree__________]

  View the file [39]lynx.cfg.

    [40]Accept Changes - [41]Reset Changes - Left Arrow cancels changes


,    went to a web-page, and tried bookmarking it (via "a").

    The above doc for multi-bookmarks says that a menu will
    pop up -- but none did.  I just hit <return>, and the
    new bookmark got added to the same old bookmark file
    I've always been using.

So, anyone have a clue as to what I'm doing wrong?

Also, for the purpose of maybe expanding it a bit,
any clue as to what I might have missed or misunderstood
in the doc on it?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]