[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] Re: rm bug again ?

From: Thomas Dickey
Subject: Re: [Lynx-dev] Re: rm bug again ?
Date: Tue, 24 Aug 2004 21:23:09 -0400 (EDT)

On Tue, 24 Aug 2004, [ISO-8859-1] Fr?d?ric L. W. Meunier wrote:

> On Tue, 24 Aug 2004, Thomas Dickey wrote:
> > On Tue, Aug 24, 2004 at 05:30:49PM -0300, Frdric L. W. Meunier wrote:
> >> I think it may be the same bug that removed my /bin in Cygwin
> >> some time ago.
> >>
> >> This time I tried to remove
> >> file://localhost/d/cygshare/misc/Windows/Add.png
> >>
> >> I don't know why it tried to remove /bin and didn't remove it.
> >
> > There are two functions that remove things in src/LYLocal.c -
> > remove_single() and remove_tagged().  The former is doing a check for
> > directory vs file, and the latter is not.  I overlooked that when I
> > changed the rm -rf's to rm -f's.
> I meant "I don't know why it tried to remove /bin". Forget the
> last part.

oh - I thought it was simply that bin was tagged and the corresponding
behavior was not expected.  (I don't recall any recent changes to the
way things are tagged, which could have introduced a bug - I use my
own directory editor for local filesystem maintenance).

> But it's very strange. Any attempt to remove that file or some
> others would result in it trying to remove /bin. It only worked
> after I restarted lynx.

Was this after running lynx for a long time?  (It could be a memory
corruption bug that we've not encountered).  Of course I prefer the
bugs that happen right away...

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]