[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] Re: rm bug again ?

From: Frédéric L . W . Meunier
Subject: [Lynx-dev] Re: rm bug again ?
Date: Tue, 24 Aug 2004 22:13:05 -0300

On Tue, 24 Aug 2004, Thomas Dickey wrote:

On Tue, Aug 24, 2004 at 05:30:49PM -0300, Frdric L. W. Meunier wrote:
I think it may be the same bug that removed my /bin in Cygwin
some time ago.

This time I tried to remove

I don't know why it tried to remove /bin and didn't remove it.

There are two functions that remove things in src/LYLocal.c - remove_single() and remove_tagged(). The former is doing a check for directory vs file, and the latter is not. I overlooked that when I changed the rm -rf's to rm -f's.

I meant "I don't know why it tried to remove /bin". Forget the last part.

But it's very strange. Any attempt to remove that file or some others would result in it trying to remove /bin. It only worked after I restarted lynx.

Remove all tagged files and directories? (y/n)
Alert!: Probable failure to remove /bin due to system error!

I'm attaching a trace.

2.8.6dev.4 on Cygwin.

How to contact me -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]