[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] rm bug again ?

From: Thomas Dickey
Subject: Re: [Lynx-dev] rm bug again ?
Date: Tue, 24 Aug 2004 17:46:31 -0400
User-agent: Mutt/1.3.27i

On Tue, Aug 24, 2004 at 05:30:49PM -0300, Frdric L. W. Meunier wrote:
> I think it may be the same bug that removed my /bin in Cygwin 
> some time ago.
> This time I tried to remove 
> file://localhost/d/cygshare/misc/Windows/Add.png
> I don't know why it tried to remove /bin and didn't remove it.

There are two functions that remove things in src/LYLocal.c - remove_single()
and remove_tagged().  The former is doing a check for directory vs file, and
the latter is not.  I overlooked that when I changed the rm -rf's to rm -f's.
> 'r'
> Remove all tagged files and directories? (y/n)
> Alert!: Probable failure to remove /bin due to system error!
> I'm attaching a trace.
> 2.8.6dev.4 on Cygwin.
> -- 
> How to contact me -

> _______________________________________________
> Lynx-dev mailing list
> address@hidden

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]