[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Unable to execute external commands

From: Thomas Dickey
Subject: Re: lynx-dev Unable to execute external commands
Date: Thu, 12 Sep 2002 20:10:30 -0400
User-agent: Mutt/1.3.27i

On Wed, Sep 11, 2002 at 07:15:06PM -0700, Umar Qureshey wrote:
> Hi,
>   I downloaded and cross-compiled lynx- for an ARM target.  The
> problem is that I am trying to launch an external program called "madplay"
> to play streaming mp3 files.  The mp3 software works great standalone (even
> with streams piped into it through another program) but, for some reason,
> lynx is not spawning it.  I have compiled with the following options:
> I am running lynx on an embedded platform so I tried to trim the fat.

you can also reduce the number of character sets which are supported
(by about 40kb, by using --with-charsets=minimal).

> In lynx.cfg, I have enabled PERSONAL_EXTENSION_MAP:/tmp/mime.type and
> PERSONAL_MAILCAP:/tmp/.mailcap
> In /tmp/mime.type, I have:
> audio/mpg mp3 MP3
> audio/mpeg mp3 MP3
> In /tmp/.mailcap, I have:
> audio/mpg;madplay -Q %s
> audio/mpeg;madplay -Q %s
> However this does not work.  It seems that lynx is not even launching
> madplay because I tried replacing madplay in .mailcap with a program called
> tone which basically emits a tone from the speaker.  But upon launching an
> audio/mpeg type stream, I heard nothing.
> Another thing I noticed is that the lynx in my potato debian installation
> has commands such as -noexec, -locexec, and -exec defined but my arm lynx
> does not.  I can't think of anything that I might be missing so any help
> would be greatly appreciated.  Thanks.

The -exec, etc., are for making lynx invoke local scripts - not a factor here.

I'd try first running lynx using the -trace option and see if anything
showed up there.  (Not an expert, the mime and mailcaps look ok to me).

Thomas E. Dickey <address@hidden>

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]