[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Unable to execute external commands

From: Umar Qureshey
Subject: lynx-dev Unable to execute external commands
Date: Wed, 11 Sep 2002 19:15:06 -0700

  I downloaded and cross-compiled lynx- for an ARM target.  The
problem is that I am trying to launch an external program called "madplay"
to play streaming mp3 files.  The mp3 software works great standalone (even
with streams piped into it through another program) but, for some reason,
lynx is not spawning it.  I have compiled with the following options:

--libdir /usr/arm-linux/lib

I am running lynx on an embedded platform so I tried to trim the fat.

In lynx.cfg, I have enabled PERSONAL_EXTENSION_MAP:/tmp/mime.type and

In /tmp/mime.type, I have:
audio/mpg mp3 MP3
audio/mpeg mp3 MP3

In /tmp/.mailcap, I have:
audio/mpg;madplay -Q %s
audio/mpeg;madplay -Q %s

However this does not work.  It seems that lynx is not even launching
madplay because I tried replacing madplay in .mailcap with a program called
tone which basically emits a tone from the speaker.  But upon launching an
audio/mpeg type stream, I heard nothing.
Another thing I noticed is that the lynx in my potato debian installation
has commands such as -noexec, -locexec, and -exec defined but my arm lynx
does not.  I can't think of anything that I might be missing so any help
would be greatly appreciated.  Thanks.



; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]