[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev TRST : see LHFB

From: Klaus Weide
Subject: Re: lynx-dev TRST : see LHFB
Date: Thu, 11 Nov 1999 11:56:08 -0600 (CST)

On Thu, 11 Nov 1999, Philip Webb wrote:

> 991110 Klaus Weide wrote: 
> PW> Supported URLs doesn't tell the user
> PW> how to get the script to process a file from Lynx;
> PW> HN's example had no input from Lynx or from any file.
> > So you may want to add some links to the usual places for CGI info.
> which are ... ? be found by you the same way I would have to look for them.
There's a whole Internet of information out there, try search

> PW> i don't believe lynxcgi is what is needed for my purpose.
> > I find 'G', ^A, x, <enter> more convenient than your key sequence.
> presumably, the document is already on-screen when you discover the tables
> & if it's serious (eg for your work), you want to print it to a file:
> the extra keystrokes are  \  n  (ie the print-screen link number),
> plus  g  & the URL if you want to re-view the cleaned-up result.
> moreover, anyone can use it: you don't need to know even awk,

except if you need to change the awk expressions in any way...

> let alone the eccentricities of lynxcgi & CERN-style rules.
> of course, it should be a single Lynx key to switch to TableSoup.
> Joe User can't & shouldn't be expected to know how to write scripts
> nor how to get them to work with Lynx: JU isn't a programmer or sysadmin.
> > you've got my script using sed (which didn't work for you),
>                                                     ^^^^^^^
> it produced error messages from the awk software on our system.
> i'm sorry, but after this exercise i'm left with the impression
> that i've discovered a tiny area in which you aren't an expert (smile):

Never claimed to be...

> it looks as if you don't know the differences between sed & awk.

...but it seems you are also confused in this respect (see above).

> sed is limited to processing whole lines one at a time:
> it can't separate lines into fields for sequential processing
> nor define variables to be retained from line to line;
> hence, it can't handle nested tables, as my awk script does.

My sed man page says otherwise.  See 'N' (not 'n') for example.
The fact that the script worked for me says otherwise.

> > You've got an awk script that reportedly works for you.
>                                 ^^^^^^^^^^
> i hope you don't question the accuracy of my report ... (smile pending)

I hope you don't question the veracity of my statement that the sed
script works for me.

> > What's the problem in replacing that sed invocation with an awk invocation?
> it doesn't work: the problem seems to be
> that awk has to be used with a separate program file (my  ltab.m1 ),

Something like
   [some command] | awk '{print $2}' | [some other command]
has always worked fine for me (although that's about all I can do in awk
without resorting to docs.)  No separate program file needed.

But if you want one, then put it within the /bin/sh (or /bin/csh) script.

> which conflicts with the format for CERN rules (in your examples).

There's no need for the RULEs to know about such internal details of
the scripts involved.

> in any case, it's unnecessarily complex.

If you think modifying the lynx source for some sort of TableSoup
behavior (which is what we started with) is less complex, then good


reply via email to

[Prev in Thread] Current Thread [Next in Thread]