lwip-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-devel] byte order, packing, optimizations


From: address@hidden
Subject: Re: [lwip-devel] byte order, packing, optimizations
Date: Sat, 13 Feb 2010 16:52:12 +0100
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I agree about the performance patches but I totally disagree about the "#warning". There's documentation how to speed up the stack, no need for annoying "#warnings" when compiling the stack as is!

Simon


Stéphane Lesage wrote:
Here are some patches:

ip_addr.patch:
- some minor optimizations in ip_addr.h
- rename ip_addr_set to ip_addr_set_safe
- new ip_addr_copy used when possible
- change ip_addr_is_broadcast to a more efficient macro
- optimization in dns.c to use SMEMCPY, and change ntoh(x)==constant to
direct comparison x==hton(constant)

<cid:part1.04070907.05070206@free.fr>warnings.patch:
def.c:
#warning LWIP_PLATFORM_BYTESWAP not defined, using defaults for
htons,htonl,ntohs,ntohl
inet_chksum.c:
#  warning LWIP_CHKSUM and LWIP_CHKSUM_ALGORITHM not defined, using
default algorithm 2
#  define LWIP_CHKSUM_ALGORITHM 2
->  algo 2 should be faster on all platforms ?

ip.h.patch:
define ttl and proto fields of ip header as 2 u8_t.





_______________________________________________
lwip-devel mailing list
address@hidden
http://lists.nongnu.org/mailman/listinfo/lwip-devel





reply via email to

[Prev in Thread] Current Thread [Next in Thread]